Meraki enrollment failing through Apple Configurator 2

Here to help

Meraki enrollment failing through Apple Configurator 2



For the last week or so I am getting error when trying to install the management profile through AC2. This has worked for the last 2 years without an issue for me.

Receiving error: Profile Installation Failed: A Connection to the server could not be established. (MCInstallationErrorDomain - 0xFA1 (4001).


I have also received an error about the enrollment certificate being invalid.


These are older iPads (iPad 4th Generation) still on iOS 10.3.3 - working on replacing them and having the new ones on DEP but these are all I have for the meantime.


Please help.

Getting noticed



I have the same problem with an Apple TV 4K, before it was working perfectly, I recently erase content due to Beta TvOS and now I am not able to enrol it again using Apple Configurator 2 !!

Try re-adding in your MDM connection in configurator and see if this fixes the issue. 

I'm using the profile to enroll, not the link you enter during the supervision process so there is no 'link' to enter...

Getting noticed

@Tom-B I ran into something similar recently.   After pushing the profile to the iPads and tapping Apply profile i would get an Invalid Profile error.


I had to disable AD authentication to complete an enrollment via AC2.  After the enrollment was completed, I then re-enabled AD authentication.

Hmm... interesting. Unfortunately we don't utilize any AD features in our setup, just reset the iPads every few months and re-enrol via using the downloaded Meraki profile in AC2.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.