Education profile not syncing

Building a reputation

Education profile not syncing

Huge issue updating our ASM populated Education Profile for Apple Classroom this year
random symptoms.
my own iPad ( which i use as a instructor ) receives that error message when trying to sync profiles :
Error: A group with the beacon ID “2” already exists

Everything seems fine on ASM side, no errors uploading. accounts and classes are well designed.

tried to remove the whole profile and redo it again but same problem

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Hello Alexis, I have a few questions for you:


1) Do you have an open case already for this? 


2) How you tried a "full sync" on the DEP page recently? 


3) What is the frequency that this occurs? E.g. We have 500 iPads in constant use and it occurs 5 times a week on different iPads.


4) Is the Beacon ID number different each time?


Noah Salzman

Product Manager for Meraki SM


1) yes created it just before my post - 04246876

2) i did à full ASM and DEP sync on the Overview page as well as from the Education profile itself.
Also tried to remove the education payload from the profile and recreate it then sync it again but same result — FYI, as soon as I checked the ASM sync option data appeared as if my datas were cached.

3) it’s happening since the back to school period
We have a little less than 2000 iPads

4) yes depending of the device/user I guess.
Just seen an ID “67” on a student’s iPad

@Noah_Salzman would it be possible that the cause is about the "cached" datas ? and maybe try to clear them ?


Hi Noah,


I have the same issue.

Case 04248982



Just browsing

Good morning,


I am having the same issue, my case # is 04225648.


The case was originally opened due to the following message that we were getting on a teacher device when trying to push a profile: "Profile - Education > Error - Error: A group with the beacon ID “327” already exists"


We were able to figure out on our own that the reason for this error was because we had not deleted older classes from Apple School Manager, so they had then synced duplicate classes to Meraki.


We reopened the ticket when we started receiving a similar error on a student profile. The new error is: "Sep 23 14:11 Update profile 'Education' Error: A group with the beacon ID “130” already exists" (Each student having the problem has a different number beacon ID).


There are no duplicate classes anymore, and these students are not duplicated. Most of them are synced to Meraki from an Apple School Manager account which was synced through SFTP from our SIS (Rediker Admin Plus). This error is happening in at least 12 students, who cannot have their profiles re-pushed due to the error.


I have also opened ticket # 04262668 for the new error. On the previous ticket that was open, my colleague re-opened it and added the new problem, and they have told her that it is a bug. I am hopeful it is not a bug because the previous issue was almost identical and we were able to solve it.


well it's about the same here.


i had "ghost classes/courses" from last year on ASM. 

Unable to delete because they were still displayed as sftp as source even when stfp disconnected.


Thought i was going to make it work even with that, because i was able to delete students and teachers from them and sync it to Meraki without any issues and without those ghosts items appearing on my Edu payload.... but teachers and students started to complain and we started to see those beacon ID errors


Apple then switched those empty classes on manual so i was able to empty everything and redo from scratch.


Still, those meraki errors remain... 


Hey All, we're actively working on a fix for this "duplicate beacon ID" issue. Don't have an ETA for you at the moment but will do so as soon as we are confident we understand the exact cause.


Noah Salzman

Product Manager for Meraki SM

@Noah_Salzman thank you for the follow up. 


We're till trying to figure out the root cause of this error; this has not been an easy problem to diagnose so far. I'll share more information once we reach the stage where we are testing a fix.



I too am seeing this affecting my district's iPads. If there is anything I can do to assist, please let me know.


I have open cases with both Meraki and Apple Enterprise support on this issue. 


One thing I have noticed is that it seems to impact both teachers and students with more than one class assigned. I have yet to see any examples in my district of just a single class causing this issue.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Kind of a big deal

@Noah_Salzman Glad to see the fix that was just pushed out appears to resolved this issue within Meraki. I will let you know if I see it occuring at any of our networks again.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

@Noah_Salzman It looks good on our end! Thanks so much!

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Glad to hear the fix is working... **cough** ... just on your shard. 😕


We have not pushed it out globally yet. 


Everyone else, hang tight.

@Noah_Salzman Sorry my excitement in it working made me want to share the good news that help is on the way. 😉

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

not part of the lucky ones here 😮



Sorry, I spoke too soon because I was excited too. After I read the post that someone's had been fixed, I checked two affected users on my network.


I only looked at the top section where it said all profiles were "Up-to-date". When I saw the profile was now up to date, I assumed that meant the error that had been preventing it from pushing was no longer occurring. I then replied that it looked like our end was working.


However, as we started to get complaints again today, and took a closer look, it seems that we now have some users whose Mangement sections indicate that their profiles are "Up-to-date",  but are still getting a beacon ID error in the event log.


I'm not sure if this means that the profiles are incorrectly showing "up to date", or if there are just some people who are still getting a beacon error even though their profiles are up to date.


I also wanted to let you know in case it is of any help, that we took a brand new iPad and set it up using one of the affected user's Apple ID/owner info, and it exhibited the same behavior.


I have updated my ticket to reflect this information as well.

Meraki Alumni (Retired)
Meraki Alumni (Retired)

We made some changes last night that should fix this issue for everyone.


You will need to perform an ASM sync.


Once you have done that the duplicate Beacon ID problem should be resolved.

New here

Do you know how to set up the classroom app on a MacBook if I am running macOS Mojave? I have found information that installing EDU profiles using the device channel is unsupported but I need more details or maybe some instructions.



Unfortunately, this functional is not ready in Meraki. They are still working on building the profile to work correctly for it. 


Apple Classroom for Mac 

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.