unbind and retain config issue

Safe_ISA
Comes here often

unbind and retain config issue

Greetings

 

 i'm facing some issue with unbind  and retain the config for some network that we have . some networks just work fine  with retain the config  but other network it gave that error

{'errors': ['Unbinding will not retain the correct config']}

 if  post that

{"retainConfigs": True}

 

if i remove that part from the post or i set to false  then it will work fine  but i will lose the config. and that will not help with my automation .

my question is there certain device model or version   that retain config is not working on . . is there any extra step i need to do it before  i post this call.

again i notice it work fine  with other networks with no issue but it just triggered  on some network.

if i do the unbind and retain config through the dashboard then  it will show ( fail to unbind)

5 REPLIES 5
Ryan_Miles
Meraki Employee

If it's working sometimes that tells me your syntax is correct. If it's still failing for some networks I would recommend opening a Support case so engineering can get to the root of the issue.

Safe_ISA
Comes here often

thank you Ryan .  i'm sure my syntax is correct  because the same syntax  is working fine with other network under . it only  with certain network that i get that error .

also i run into same  error if i do that  through the  meraki dashboard by  hit the unbind button and select unbind and retain config

 

Unbinding Failed!

Selected networks failed to unbind from template <templet name>as some of the configurations could not be retained.

 i had ticket already open with Meraki support   still waiting their response . i assume that there is some setting the templet that prevent that unbind  but not sure which one

AutomationDude
Building a reputation

Hello,

 

Were you able to get any idea for why this API call fails on certain networks? I'm working on a similar script and would was curious to know if you've been able to find any patterns. 

 

Thanks!

Safe_ISA
Comes here often

no nothing yet . i also have ticket open and waiting their response.

in meantime  the way how i by pass this  issue and automate the process  . is by  getting all the current config for the network  then remove the old network , then push the config to the new network that not using any templet

mjheaberlin
Conversationalist

I'm seeing this same exact issue. We have unbound hundreds of networks, but there are 3 that we get an error on. We're using the Meraki dashboard to do this. I downloaded and analyzed the HAR data to find the "unbinding will not retain the correct config" response. Meraki support suggested it was trying to save MX and MR configs, but the network was switch only. We appeased their request by creating a combined network and then retrying but still receive the same error.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.