Vlan problem

Here to help

Vlan problem

We use Wifi to provide networking on moving irrigation booms - 65 of them. See the attached image. We have a separate SSID and vlan for these moving devices. This system has worked dependably on a Ubiquiti wifi system, but the Ubiquiti cloud key/module has been flaky.


We upgraded a portion of our system to a Meraki MR76 WiFi system using the same ssid/vlan settings, and have had mixed results. The native vlan (vlan1) has been rock solid. The irrigation vlan (vlan2) is where we're having issues. The settings are the same in Meraki as Ubiquiti as far as we can tell.


On the Meraki system, we are sometimes able to ping the devices (from the server) behind a Netgear router, but are unable to ping the router or access the Web interface. Vlan 2 is entirely static IP, since all the communication from server to device is IP based. It puzzles me how we can have devices with a static IP address, and some are reachable by ping and others are not. Wait a bit, and we might be able to ping the devices that were not "pingable" a few moments ago.


Any help would be greatly appreciated.  Thanknks


Meraki vs Ubiquiti.jpg

4 Replies 4
Kind of a big deal
Kind of a big deal

Have you configured a Trunk on the uplink from the Meraki switch to the AP with the Native vlan set?  Then on your SSID you’re Tagging VLAN2?


What are you seeing in Wireless > Health?

Darren OConnor | doconnor@resalire.co.uk

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.

All ports on both Meraki switches are configured as Trunk on the Native vlan.

And the SSID is tagged as VLAN2.


Wireless->health shows

  1. 0% fails on connection steps
  2. 0 connection problems by Client
  3. 0 connection problems by AP
  4. Less than 10ms latency on that AP, up to 11 on others
  5. Some authentication problems on several of the APs (but not from the devices we're talking about)
Kind of a big deal
Kind of a big deal

Can you check the wireless profile assigned to your meraki ap's.


In would try this:

Disable band steering.

Disable client balancing 

5ghz channel set to 20Mhz

ax disabled

Thanks.  We tried doing this (band steering was already disabled, but we changed all the others)

It does not seem to have made any difference - certainly not better

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.