MR36 Access Points IP addresses not changing to static when instructed but are within switch page

Solved
phelimmc
Here to help

MR36 Access Points IP addresses not changing to static when instructed but are within switch page

Hi,

Can anyone advise please why the IP address of an AP is not changing to static when instructed within their web portal but shows within the switch page as the correct static IP address.

For example within Wireless->Access Points->AP1 displays as LAN IP (DHCP) even though it has been changed to a static IP address. 

When you select Switch->Switches below Clients AP1 displays as the static IP address you have assigned it. What can be causing this mismatch of the switch recognising the correct AP address but the AP not within it's page?

1 Accepted Solution
Ryan_Miles
Meraki Employee
Meraki Employee

Are you setting it to a static IP on the same VLAN it's using the DHCP IP from? Or, changing to an entirely different subnet/VLAN? Typically this happens when the address you're attempting to use is failing to work and the AP (or even a switch or MX) will defer back to using DHCP.

 

I think I found your network. If this is yours I see you have the AP static IP set and VLAN 13 specified. You also have native VLAN 13 on the upstream port. You can't tag the AP mgmt IP and have it native/untagged on the switch. Easiest fix just delete the VLAN tag on the AP static IP config.

Ryan / Meraki SE

If you found this post helpful, please give it Kudos. If my answer solved your problem click Accept as Solution so others can benefit from it.

View solution in original post

6 Replies 6
Ryan_Miles
Meraki Employee
Meraki Employee

Are you setting it to a static IP on the same VLAN it's using the DHCP IP from? Or, changing to an entirely different subnet/VLAN? Typically this happens when the address you're attempting to use is failing to work and the AP (or even a switch or MX) will defer back to using DHCP.

 

I think I found your network. If this is yours I see you have the AP static IP set and VLAN 13 specified. You also have native VLAN 13 on the upstream port. You can't tag the AP mgmt IP and have it native/untagged on the switch. Easiest fix just delete the VLAN tag on the AP static IP config.

Ryan / Meraki SE

If you found this post helpful, please give it Kudos. If my answer solved your problem click Accept as Solution so others can benefit from it.
phelimmc
Here to help

Yes it's the same VLAN we are using DHCP from, all the switches revert to static IP without issue but for some reason the AP's don't or don't reflect the change to static addressing on the relevant AP page. 

Ryan_Miles
Meraki Employee
Meraki Employee

You read the second paragraph of my response yes?

Ryan / Meraki SE

If you found this post helpful, please give it Kudos. If my answer solved your problem click Accept as Solution so others can benefit from it.
phelimmc
Here to help

Fantastic well done! you have sorted it 🙂 just assigning the static IPs to the relevant APs. Much appreciated. For my knowledge why can't you tag the AP mgmt IP and have it native/untagged on the switch?

Basic .1Q trunking rules. Your switch was expecting untagged VLAN 13 traffic. If you send it tagged from the AP the switch is going to see a mismatch.

 

In short, if it's the native VLAN = no tag. Anything besides the native = tagged.

Ryan / Meraki SE

If you found this post helpful, please give it Kudos. If my answer solved your problem click Accept as Solution so others can benefit from it.
phelimmc
Here to help

Thank you

Get notified when there are additional replies to this discussion.