cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wi-Fi clients not obtaning DHCP Address

SOLVED
Highlighted
Here to help

Wi-Fi clients not obtaning DHCP Address

Issue is that none of the Wi-Fi clients receive an answer to their DHCP request (Windows 10, Apple iOS, and Apple MacOS Tested). The MR45 devices are DHCP themselves do receive an IP from the same DHCP Server, in the same VLAN.

 

Access Points: MR45 Firmware: MR 25.13

Switch: Cisco C2960XR Ver: 15.2(2)E4

 

SSID in Bridge mode, with VLAN Tagging.

AP Tags for APs, setting VLAN ID to 3

 

Cisco port config:

interface

    switchport trunk native vlan 3
    switchport mode trunk
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust dscp
    auto qos trust

interface Vlan3
    ip address ###.###.3.254 255.255.255.0
    ip helper-address ###.###.1.15

 

DHCP Server is Windows Server 2008 R2, no errors logged in the event log from the DHCP-Server. 60% of the IP addresses in range of DHCP Scope are available.

 

Wi-Fi clients joining the same VLAN from Cisco AP devices do not have the same issue.

 

Side note: I have a different SSID for a guest network, on the same Meraki APs set at Bridge Mode as well, but the DHCP request are handled local to the VLAN. This is working with no issues.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Kind of a big deal

Re: Wi-Fi clients not obtaning DHCP Address

The "native" VLAN is the untagged VLAN.  On your swicth port you have said "switchport trunk native vlan 3" - so don't use tags for VLAN3.

 

Then on your SSID you said to tag it using VLAN3.  Not a valid config.

 

Change the SSID to bridge but don't use a tag.

View solution in original post

6 REPLIES 6
Kind of a big deal

Re: Wi-Fi clients not obtaning DHCP Address

First I would upgrade to 26.4 as soon as you can. That firmware build is specific to the new MR45 and MR55 with tons of fixes.

Also the AP TAG that your referring to should be specific to the SSID, not the AP VLAN (that's controlled by the switch port config, of which you have native set to 3 which is fine).
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Here to help

Re: Wi-Fi clients not obtaning DHCP Address

Now running 26.4 on all APs.

 

Still have to the same issue.

 

DHCP Failures from the LAN tab for the AP that the test device is connecting to.

 

DHCP request status on VLAN 3

5 of the last 5 requests did not receive responses.
 
Req. ID Client MAC Server IP Req. IP Req. type Resp. type Resp. IP RTT(ms) Ago( 
247527957fc:18:3c:61:a2:91Discover26
247527957fc:18:3c:61:a2:91Discover24
247527957fc:18:3c:61:a2:91Discover20
247527957fc:18:3c:61:a2:91Discover11
247527957fc:18:3c:61:a2:91Discover2

 

You were correct on the AP TAG statement, that was for the VLAN Tagging in SSID configuration, not the VLAN setup for the APs. Thanks for clearing that up.

 

Dan

 

 

Getting noticed

Re: Wi-Fi clients not obtaning DHCP Address

Is dhcp snooping configured on the switch? If yes is the uplink to your DHCP server trusted? Also perhaps try „no ip dhcp snooping information option“ if using that feature.

Can you post a screenshot of the SSID config (the VLAN tagging section) and the current switchport configuration?

And last but not least if this is a new VLAN: Does the vlan 3 actually exist on the switch? „show vlan id 3“
Kind of a big deal

Re: Wi-Fi clients not obtaning DHCP Address

The "native" VLAN is the untagged VLAN.  On your swicth port you have said "switchport trunk native vlan 3" - so don't use tags for VLAN3.

 

Then on your SSID you said to tag it using VLAN3.  Not a valid config.

 

Change the SSID to bridge but don't use a tag.

View solution in original post

Here to help

Re: Wi-Fi clients not obtaning DHCP Address

I get it, the access point should not be in the same VLAN as any tagged VLANs listed in a SSID.

 

I will try that during the next round of test, and provide feedback.

 

 

Here to help

Re: Wi-Fi clients not obtaning DHCP Address

Move the native cisco cli command to a different VLAN that will not be used in "VLAN Tagging" worked.

 

Thanks PhilipDAth, and all other for the helpful replies.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.