RX-SOP - SNR and RSSI

SOLVED
Theulis
Here to help

RX-SOP - SNR and RSSI

Hello all,

I would like to explore the RX-SOP option
https://documentation.meraki.com/MR/Radio_Settings/Receive_Start_of_Packet_(RX-SOP) 

mainly because of the MACOS stickiness issue.
MACOS devices tend not to roam to another access point even if the RSSI is -75dBm.
https://support.apple.com/en-us/HT206207

The Meraki portal (under client) shows values in SNR even if this is called signal!
https://documentation.meraki.com/MR/Wi-Fi_Basics_and_Best_Practices/Signal-to-Noise_Ratio_(SNR)_and_...

I am aware that SNR = RSSI - Noise. But how can I find the noise level on the Meraki Portal for a specific AP, so I can calculate the RSSI. We use MR33/42/53.

Is there another way to find the RSSI, so I can set the RX-SOP limits? I am also aware that I can find the noise on my Laptop, but I assume that value is different on the AP, and also Meraki suggests that WLAN cards are not designed to measure noise floors.

The typical WLAN card on a laptop is not designed to measure the noise floor of its surrounding and special adapters like the Wi-Spy dBx are needed

Screenshot 2023-03-09 at 09.16.44.png




1 ACCEPTED SOLUTION
GIdenJoe
Kind of a big deal
Kind of a big deal

802.11k should always be on @PhilipDAth, that feature is related to roaming but is quite different than 802.11r.

For Apple devices you have two requirements to roam.  The RSSI at the client from the currently connected AP must be below -75 and the signal of the candidate AP needs to be at least 10 dB higher.  So if your network is not designed with enough overlap/secondary AP signal then you'll have sticky clients.

 

RX-SOP is only to be used in environments with lot's of AP's from own installation and neighbor installation that interfere with each other.  It does NOT help in any way for your roaming.

 

To calculate your RSSI from your SNR you could take -92 dBm as noise floor on 2.4 GHz and -95 dBm on 5 GHz and add our SNR to that to get the RSSI.

View solution in original post

10 REPLIES 10
alemabrahao
Kind of a big deal
Kind of a big deal

Just remember that roaming is a client decision. By the way, how is the minumum bit rate configured?

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Thank you. Unfortunately with MACOS there is no way (unless I am missing something important) to change that behavior, while with Windows OS there are settings like roaming aggressiveness etc.

So I am trying to solve this through Optimized Roaming on the AP level.

https://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/8-0/hdx_final/b_hdx_dg_final/hig...

Bit Rate: 18Mbps at the moment, I can increase it to 24Mbps or 36Mbps.

GreenMan
Meraki Employee
Meraki Employee

I don't believe changing RX-SOP will help you here - it affects how APs treat received frames, whereas it appears that Macs look only at the RSSI as they see it, when making choices about which AP to use.   In general I'd be very careful messing about with RX-SOP - I would certainly think about talking to Meraki Support via a case, beforehand.

Thank you. I will definitely raise a case with Meraki.
Changing the RX-SOP is my last option and I am not sure if this has the results I believe, but at the moment there are so many problems: lack of a proper wireless site survey, MAC stickiness, DFS, high density, high interference from other offices is, so I need to try a few things because the end user experience is really bad.

PhilipDAth
Kind of a big deal
Kind of a big deal

If you aren't using 802.11r, try setting it to adaptive (or enabled).  This also enables 802.11k.

 

PhilipDAth_0-1678385020449.png

Mac OS does use 802.11r for roaming assistance.

https://support.apple.com/en-nz/HT202628 

Thank you. We are using Adaptive. I have also tested with Enabled. Unfortunately, there is no difference. Actually, my MACOS device supports 802.11r.

In general, the MACOS devices won't move to a better AP, unless I disassociate them from the SSID. Turn Wireless OFF/ON still doesn't fix the problem

sudo /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport --disassociate 



Based on my understanding the APs cannot enforce roaming.

The clients driver uses the received signal strength of beacons or probe responses to make decisions on whether to change APs or remain connected to the current AP.

https://documentation.meraki.com/MR/Wi-Fi_Basics_and_Best_Practices/Client_roaming_and_connectivity_...

alemabrahao
Kind of a big deal
Kind of a big deal

Check it out:  https://support.apple.com/en-is/HT202068

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
GIdenJoe
Kind of a big deal
Kind of a big deal

802.11k should always be on @PhilipDAth, that feature is related to roaming but is quite different than 802.11r.

For Apple devices you have two requirements to roam.  The RSSI at the client from the currently connected AP must be below -75 and the signal of the candidate AP needs to be at least 10 dB higher.  So if your network is not designed with enough overlap/secondary AP signal then you'll have sticky clients.

 

RX-SOP is only to be used in environments with lot's of AP's from own installation and neighbor installation that interfere with each other.  It does NOT help in any way for your roaming.

 

To calculate your RSSI from your SNR you could take -92 dBm as noise floor on 2.4 GHz and -95 dBm on 5 GHz and add our SNR to that to get the RSSI.

Thank you. The problem with MACOS is that, based on my understanding, no matter the overlapping, the client can "get stuck" within an area of let's say -72dB to -73dBm. I experienced this case below, where I was not able to roam, unless I disassociate / associate. Turn Wireless OFF / ON doesn't fix the problem.

https://support.apple.com/en-us/HT206207
Consider this threshold in view of the signal overlap between your wireless cells. macOS maintains a connection until the -75 dBm threshold, but 5 GHz cells are designed with a -67 dBm overlap.

Screenshot 2023-03-10 at 11.37.52.png

 

I was hoping to fix this with RX-SOP - Cisco Marketing advertisement worked for me 😁, but thank you for the update. Based on your feedback and the more I read about this feature the more I am convinced that this is not the way to move forward, but it could help with other things you mentioned, like other AP interference.

 

Screenshot 2023-03-10 at 11.41.44.png

GIdenJoe
Kind of a big deal
Kind of a big deal

If you configure RX-SOP your clients won't know about it.  You basically just tell the AP to not listen to frames below a certain RSSI threshold and transmit over them at those levels if you have stuff to send.

It won't help one bit with roaming,

 

 

The only way to have good roaming is having the correct coverage (which means enough secondary AP signal) so the client can easily see both AP's and the AP's see each other a bit which helps with info contained in 802.11k and 802.11v which in turn will help clients find the next AP faster and have a better time roaming.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels