Forcing SmartLocks to associate to a specific AP

CWK_Rob
Getting noticed

Forcing SmartLocks to associate to a specific AP

Ho Folks,

 

I have a multi unit residential building.  Each unit is equipped with a smart door-lock and smart thermostat connected to the building's SmartHome Wifi SSID and VLAN.

 

I'm having some problems with locks jumping their AP associations back and forth between APs, which is really draining the batteries in each smart lock a lot fasther than they should.

 

Is there a way to force a particular client to only associate with a single AP?

9 REPLIES 9
BrandonS
Kind of a big deal

I don't know a way to lock a client to one AP, but you can broadcast the SSID from only a single AP.  Would that work for you?  Maybe you need multiple SSID's in this case like doorlock1 and doorlock2 each on it's own AP.

 

https://documentation.meraki.com/MR/Other_Topics/Using_Tags_to_Broadcast_SSIDs_from_Specific_APs

MerakiDave
Meraki Employee

Hi @CWK_Rob the semi-official answer is no.  This is ALWAYS the client's decision, which AP to connect to and when to roam.  Every client of course will have its own unique perspective of the RF environment and make its own decisions accordingly.  Plus every client device will approach such decisions depending on the underlying OS, chipset and driver versions, etc.  So even client devices from the same manufacturer, but perhaps with different OS or driver versions, can behave differently for how they associate and roam.  Very client dependent and lots of variables, not to mention the actual RF in your residential building, which can literally change from minute to minute based on doors opening/closing, people moving around, etc.  

 

If these are the only clients connecting, you can make some adjustments like with radio transmit power, RX-SOP, or minimum bit rate settings to expand/contract the effective coverage cell.  But if other client devices are also connecting for other purposes, proceed with caution when making certain adjustments.  

 

And as Brandon mentioned, perhaps another possibility is to leverage AP tags and SSID Availability for a separate SSID with fine tuned settings that will encourage the locks to join the AP you intended.  But notice I said "encourage" and not "force".  We can fine tune and encourage the clients to behave the way we want, but cannot force them.  

 

PhilipDAth
Kind of a big deal

Following on from @MerakiDave , I would try increasing the minimum bit rate first.  If you are not using 12Mb/s, start by trying to raise it to that.

https://documentation.meraki.com/MR/Radio_Settings/Minimum_Bitrate_Control 

Hi @PhilipDAth 

I have been using 24MBps since the building opened

PhilipDAth
Kind of a big deal

Any firmware updates available for the smart locks?

CharlieCrackle
Building a reputation

I have seen this before.  in my case it was channel utilization and co-channel interference.    It could be Channel utilization especially if they are 2.4Ghz  it might be high causing a lot of retries and using more battery power.

you need to measure the AP signal strength at the device and make sure it has enough for the min data rate and MCS rate it is connected at.   co-channel interference from other devices the tenants have causing excessive re transmits.

 

This also assumes the WiFi was designed to work at MIN data rate of 24Mbps  these higher modulations require more power to transmit and decode but are quicker to transmit if no retries.  IoT devices generally are LOW speed low, bandwidth  and like low MCS rates as the radios are poor compared with a PC.   you might want to have a separate SSID just for these devices with lower data rates if the WiFi was not designed for 24Mbps on 2.4Ghz.     At these rates I could guarantee co-channel interference on 2.4hz with all the AP so close to support these rates and with only 3 non overlapping channels

Thank @CharlieCrackle !  I have some time to focus on this issue this week, so I can experiment.

 

I do have all SmartHome devices on their own SSID and VLAN.  For that SSID, I will lower the minimum bitrate to 11 - Schlage (lock manufacturer) also supports that line of thinking - "ENGAGE devices requires the Mandatory Connect Data Rate setting to 24Mbps or lower". 

I also noticed that ALL locks have connected using 2.4GHz, so I will turn off 5GHz for that SSID.

 

Finally, I'm going to increase the DHCP lease time on that VLAN to 1 week, rather than 1 day.  That should also help decrease re-connect activity.

Oh, that's interesting.

Aro
New here

I would go with raspberry pi, it can handle more modules and different types of variations, so I would try using raspberry. I would advise you to find an emergency locksmith e11 and install a smart lock first of all just to have a look at what those locks look like and what functions it has. A good idea to test them, but I would recommend you test 3 or 4 locks, at the same time, different types of smart locks, to see which one works better and faster. One of them, I would take apart to see how they are built and what is used there.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels