cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Android Phone Splash Page Redirect Issue

SOLVED
Conversationalist

Android Phone Splash Page Redirect Issue

I am hoping you all can help me because this is a head scratcher and this is only happening at one of my sites and only on android devices because all IPhone devices will work.  The issue with users are accessing the web it is redirected to a splash page for the users to accept an agreement to continue onto the internet.  For the iphones it is re-directing to a captive portal page where we have to hit done and then the end users are onto the webpage they want to go to.  However, this is not the case for the android devices.  When the android devices are trying to access a web page it is not getting redirected to our splash page.  It asked to open a browser and the user either gets a blank screen or it eventually times out and gets an error: empty_reponse.  Like below:

error.jpg

I have checked my other sites and the access control and splash page configuration are exactly the same and my other sites have no issues with android phones.  Also my firmware on these aps meraki aps are up to date as well.  Any help will be appreciated.  Thanks everyone.

1 ACCEPTED SOLUTION

Accepted Solutions
Head in the Cloud

Re: Android Phone Splash Page Redirect Issue

Hi@cisconovice77 

 

Hope you have already referred this documentation.

https://documentation.meraki.com/MX/Access_Control_and_Splash_Page/Troubleshooting_the_Splash_Page_A...

 

Excerpts from the above documentation

Web Browser Times Out Instead of Loading the Splash Page

There are some circumstances where an unauthorized user will open up a web browser with the intention of hitting the Splash page to authenticate, but the web browser times out or fails to load the page. This will commonly occur when the user was attempting to access a web site via HTTPS.

When the AP or security appliance sees an HTTP GET request from a non-authenticated user, it will redirect that request to its configured Splash page. If the user's initial request is using HTTPS, however, their request is encrypted and therefore cannot be redirected. As such, the request will time out.

To troubleshoot this issue, the user should clear their browser cache and try to access any website using HTTP (at this time, bing.com supports the use of unencrypted HTTP). If the issue persists, ensure that the client has a valid IP configuration, and troubleshoot for other possible network issues.

Blank Page Loads Instead of Splash Page

Since Splash pages rely on cookies to function, a blank page will appear if cookies are not enabled on the user's web browser. This is most common on mobile devices, but can be configured on any modern browser.

To resolve this issue, ensure that cookies are enabled in the web browser. Please refer to browser-specific documentation for details:

Splash Page Loads but Post-Splash URL Doesn't On Android

On Android devices running OS version 5.0 or later, the URL set on "Where should users go after the splash page" in Dashboard will fail to load successfully. This is an expected behavior of Android OS 5.0+.

Cheers
Ajit
ajitsnw@gmail.com
https://www.linkedin.com/in/ajitkumarverma/

View solution in original post

4 REPLIES 4
Head in the Cloud

Re: Android Phone Splash Page Redirect Issue

If the splash page is hosted on a outside server there might be an issue with DNS. Usually the way Android will work is ping the gstatic page before going there. Also you may want to wait a min to get the sign in now notification on the phone.

 

 

Head in the Cloud

Re: Android Phone Splash Page Redirect Issue

Hi@cisconovice77 

 

Hope you have already referred this documentation.

https://documentation.meraki.com/MX/Access_Control_and_Splash_Page/Troubleshooting_the_Splash_Page_A...

 

Excerpts from the above documentation

Web Browser Times Out Instead of Loading the Splash Page

There are some circumstances where an unauthorized user will open up a web browser with the intention of hitting the Splash page to authenticate, but the web browser times out or fails to load the page. This will commonly occur when the user was attempting to access a web site via HTTPS.

When the AP or security appliance sees an HTTP GET request from a non-authenticated user, it will redirect that request to its configured Splash page. If the user's initial request is using HTTPS, however, their request is encrypted and therefore cannot be redirected. As such, the request will time out.

To troubleshoot this issue, the user should clear their browser cache and try to access any website using HTTP (at this time, bing.com supports the use of unencrypted HTTP). If the issue persists, ensure that the client has a valid IP configuration, and troubleshoot for other possible network issues.

Blank Page Loads Instead of Splash Page

Since Splash pages rely on cookies to function, a blank page will appear if cookies are not enabled on the user's web browser. This is most common on mobile devices, but can be configured on any modern browser.

To resolve this issue, ensure that cookies are enabled in the web browser. Please refer to browser-specific documentation for details:

Splash Page Loads but Post-Splash URL Doesn't On Android

On Android devices running OS version 5.0 or later, the URL set on "Where should users go after the splash page" in Dashboard will fail to load successfully. This is an expected behavior of Android OS 5.0+.

Cheers
Ajit
ajitsnw@gmail.com
https://www.linkedin.com/in/ajitkumarverma/

View solution in original post

Kind of a big deal

Re: Android Phone Splash Page Redirect Issue

Try adding *.gstatic.com to the walled garden url's. I have a feeling the phone is trying to access that first.

Conversationalist

Re: Android Phone Splash Page Redirect Issue

Thank you for your assistance on this issue.  That seems to fix the issue.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.