VPN_client no conecta

heriberto087
Here to help

VPN_client no conecta

Hola que tal.

 

Estoy configurando VPN en un MX64, pero me he encontrado con el problema de que no se logra establecer el tunel.

 

Tengo dos servicios de internet, no tengo ip pública dedicada, el meraki obtiene la ip publica que utiliza por default el modem del proveedor de servicio. Mi duda es ¿de que si la VPN no conecta por que necesita forzosamente una direccion ip publica privada?

 

Saludos.

6 REPLIES 6
alemabrahao
Kind of a big deal
Kind of a big deal

You need to use your public IP to connect on VPN.

Have you tested configuring the Anyconnect?

 

https://documentation.meraki.com/MX/Client_VPN/AnyConnect_on_the_MX_Appliance

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
heriberto087
Here to help

Hello. If I'm testing anyconnect configuration, I use the public address associated with the Meraki hostname, only it's a shared public address assigned by the internet provider to their modem so that many users can exit through it. It is not a dedicated public IP.

 

You need a dedicated IP, Meraki Client VPN doesn't work behind NAT.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
roqe360
Getting noticed

Hola heriberto087, si es un ADSL con algunos ISP's se deben forwardear los puertos para establecer la VPN, y en algunos otros proveedores debes utilizar forzosamente una IP Publica fija ya sea en el adsl o en tu equipo.

Tengo un MX250 conectado a 23 sucursales y eso he experimentado y solucionado con una IP pública fija.

Espero sea de utilidad. saludos 

Maumarti
Meraki Employee
Meraki Employee

Mi experiencia es que sí puedes establecer meraki client VPN (o, alternativamente, con el anyconnect) sin contar con una IP dedicada en tu modem de internet.

 

El "truco" está en especificar unas reglas de port forward en tu modem (de puertos UDP 500, 4500 para client vpn, y usé tcp/udp 443 para anyconnnect).

O sea, las regla dice que tráfico de entrada que llegue al modem, de esos puertos, se avance a los mismos puertos a la IP WAN del Meraki MX que está detrás del modem.

Y en el client vpn o any connect, se usa el hostname del meraki MX que ves en appliance status (no especificas una IP). De esa forma, si cambia la IP de tu modem, a los 5 minutos aprox ese hostname meraki lo va a actualizar con el valor de esa nueva dirección pública.

 

Yo tengo también dos internets sin IP fijas, y eso lo hago en los dos modems para que funcione.

Que tal, si ya está funcionando, ciertamente así lo hice,  de hecho dejé fuera los puertos 500 y 4500, solo está reenviado el 443 y con eso está jalando.

 

Solo me está permitiendo las VPN client con el anyconnect, por que con las vpns de windows y android no quiere conectar.

 

Saludos.

Get notified when there are additional replies to this discussion.