Unable to reach Meraki cloud

Getting noticed

Unable to reach Meraki cloud

I have a test lab network that I created that contained 3x MS350-48FP switches that I had physically stacked. I had finished testing and the stacking cables, etc were disconnected and placed on a shelf in our storeroom for about 7 months. I needed to use one of these switches in our production network today, so I removed the stack in the dashboard and moved one of the switches into the production network. I connected the uplink and it will not reach the cloud, which made sense since the uplink in the test network was in a different vlan than prod network. I connected a laptop, went to and into the local device page. I change the uplink config to use DHCP and entered the correct vlan and clicked save. Still no connectivity to Meraki cloud. I checked the port status tab and uplink is connected at 1gbps to an upstream meraki switch that has connectivity to the Meraki cloud. If I plug a laptop into the cable I'm using for the uplink, I get a dhcp address on the expected network and can browse the web, ping meraki cloud IP's, etc. I confirmed the port on the trouble switch was a trunk allowing all vlans. I also tried it as an access port in the uplink vlan and still no connectivity. I've factory reset the switch about 5 times now, even cycling the power a few times too. The local device page is retaining the correct uplink vlan and ip settings. I've also tried a static ip in the prod vlan.


After all of this, I called Meraki support and advised the things I tried. We tried the factory reset, dhcp, static ip steps again just in case there was something I may have missed, and the tech decided it was a bad switch and kicked off an RMA about 30mins ago.


So I went and grabbed one of the other switches that was previously in this stack, and repeated the steps above and same issue. I find it hard to believe that the 2nd switch is also bad.  I am bout to go and try the 3rd switch that was in this stack.


Wondering if anyone has experienced a similar issue, and there's maybe something I've missed?


Do you have the option of connecting the switch to a "simple" internet connection (i.e. DHCP, no VLANs and open firewall), just to allow it to connect to the dashboard, get its firmware and config?

View solution in original post

Head in the Cloud



My first thought is if these switches have been sitting for 7 months, could it possibly be a mismatch of switch firmware causing the issue?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

They are definitively on different firmware than the rest of the switches in the prod network. The switches with the issue are running 11.22 and the rest of the switches in the prod network are on older 10.45 i believe. The prod network has not been updated in quite some time. 


I didn't think firmware would stop switches from reaching the cloud though?

Kind of a big deal

I know it might be a hassle, but if you could get a packet capture inline to see what the switch is doing it would probably help and reveal the problem to you or support.  I think you need to use a tap/hub,etc though because I recall you can't capture some/all Meraki management traffic with an MX.



Do you have the option of connecting the switch to a "simple" internet connection (i.e. DHCP, no VLANs and open firewall), just to allow it to connect to the dashboard, get its firmware and config?

Kind of a big deal
Kind of a big deal

Or as you have them all, reconnect stack and connect as before as that might allow connection to break stack.

Thanks. I'll give that a go and report back 🙂

Thnaks BrechtSchamp. This resolved the issue. Connectivity to cloud good and switches downgraded firmware from 11.22 to 10.45.

Strange though as we have a bunch of other Meraki's on this same network working fine, and the laptop connected to the same port gets dhcp address and internet connectivity.


Time to fess up as I worked out what the issue was haha


I received the RMA replacement switch and just got a chance to test it today. I still couldn't connect to the cloud, so I took the switch into one of our IDFs and connected it up to one of our access switches in there. I logged onto the dashboard and looked at the port on the upstream switch I just plugged into......low and behold it's being blocked by BPDU Guard. You'd think the person that set this up (me) would have remembered and thought to check this lol.


Anyway thought I'd better fess up to my mistake, and hopefully give someone a chuckle. I laughed when I realized it 🙂



Thanks for sharing your f***up with us. It may help someone in the future!

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.