STP root bridge page for configuration

Comes here often

STP root bridge page for configuration

Hi , 

as per the documentation, i'm supposed to configure a root priority number on the 'switches/stacks' location. 

My dashboard has 'Switch Stacks', however I have no stacks and therefore no switches show up on this page. 

How do I set my root to be the core switch in this case?

12 Replies 12
Getting noticed



Click on the link "Set the bridge priority for another switch or stack" under switches/stacks location.

Then click on "chose Switches" --> Select the Switch --> Assign the bridge priority --> Save


Please mark as solution the useful replies.

Comes here often

THanks, I read this before posting. 

This is all i see on this page. Its not clear, but I guess I click on ádd one' when I'm not configuring stacks on the network and then choose a single switch and change the priority?

Switch stacks overview
Configured stacks
There are no configured stacks in this network. If you add one, we can help you configure it.
Detected potential stacks
No potential stacks detected
Kind of a big deal
Kind of a big deal

You should be looking here:




I just did it with a non-stacked switch, and it worked fine.




Thanks, When I hover on my Switch tab under a created network I get less options:


Switch ports

Switch Stacks

Dhcp servers/arp 

Routing and dhcp

Building a reputation

Sounds like you are not an admin for that network?

Comes here often

hmm, good point. I checked and out of none, read only and full. I have full

Building a reputation

This is very weird, are you sure your dashboard is loading properly?

Do you see the status of your switches? What models do you use?


For a test - try maybe to hand craft the url to that section:

Go to the Monitor -> Switches part

replace the end of the url (so this part /manage/switches/*)

with /manage/configure/switch_settings


Comes here often

That was a good idea, I did switch_settings at the end, and it takes me to 


Kind of a big deal
Kind of a big deal

It doesn't sound like you are a full admin.  Perhaps you have read-only access?

Hi All, its due to using a Template. If I go into the template I can see the option. BUT, i don't want to apply this change to all my networks. 
So i'm asking support how I can target each switch across all my networks to receive the change in priority only. 

I have a suspicion i'll have to unassign from the template. 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.