Showing results for 
Show  only  | Search instead for 
Did you mean: 

SONOS Play:1 and UDLD error


SONOS Play:1 and UDLD error

I am having no luck at all connecting a SONOS PLAY:1 to a port of my MS210-BLP

Every port setting I have tried results in a UDLD error on the port and then loops and meltdown and the only state I can recover to means leaving the PLAY:1 off the wired network 

I have a SONOS controller connected to the same switch and following the advice I read here:

I have enabled RTSP on the ports connecting to the SONOS CONTROLLER but it does not matter what I set to the PLAY:1 (RTSP ENABLED / DISABLED) still results in a UDLD error 

Any suggestions appreciated ?

Kind of a big deal

Re: SONOS Play:1 and UDLD error

I have a Play:3 connected to my MS220-8P without issues. It is running at 100Mbps though, which is the max speed of the interface on the Play:3, and I'm pretty sure also on the Play:1. 100Mbps is plenty for music streaming.


How do you have the port configured?

Do you have multiple speakers wired up?


I only have a single one wired up, the rest connect to this one Play 3 over the Sonos proprietary wireless mesh network. I found this to be the best setup.


My switchport has the default configuration:



When you wire up multiple Sonos devices to the same network your Meraki network might detect a loop as I think by default the Sonos builds a L2 bridge between the wired ports of multiple Sonos devices in the same network. In that case you might have to fiddle with the port settings (although I think STP will handle this fine).


Re: SONOS Play:1 and UDLD error

This is the basic config I have been trying with my switch with RTSP toggled both on and off and in each case I have seen UDLD errors

I do notice that your port is set to TRUNK where I have been using ACCESS

Screenshot 2019-02-05 17.34.47.png

Kind of a big deal

Re: SONOS Play:1 and UDLD error

If UDLD is kicking in you may also have a cabling issue.  Have you tried patching directly in with a different patch lead?


Re: SONOS Play:1 and UDLD error

Thanks for the suggestion - honestly I have swapped cables ad infinitum 

I have actually just realised though that the Play:1 has associated with the home WiFi and works over that with no issue for now so I have pulled the ethernet cable and see what happens  

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.