Meraki not able to pull an IP from InfoBlox server


Meraki not able to pull an IP from InfoBlox server

I am configuring a MS-425 and trying to get it to pull DHCP from infoblox. 


Management is set to VLAN 911, port is set to 911. Have tried it as trunk and access port both.


When uplink is in place and another port is in vlan 911 a laptop can pull an IP from the scope correctly. Is there a DHCP option that the Meraki is looking for on the scope that it is not seeing?

Kind of a big deal
Kind of a big deal

should work without options, did you make a capture on the infoblox to see if you receive a discover? and send and offer?

did you try factory reset the switch?

Head in the Cloud

It sounds like you're getting double tagging happening. I.e Management VLAN being tagged 911 and then a Native VLAN tagging of 911. Try to remove the management VLAN tagging or alternatively use a different Native VLAN.


If this doesn't work take a packet capture on the device connected to the MS to see what VLAN the DHCP discovers are coming from.


Eliot F | Simplifying IT with Cloud Solutions
Found this helpful? Give me some Kudos! (click on the little up-arrow below)

Thanks for the response. After some troubleshooting and being able to pull an IP intermittently we determine that our SVI only had a single DHCP helper address and the Infoblox grid would fail because it was set to have failover on the server. Basically if only one server was visible it worked. If both were on line it would give an error. 


Meraki did not appear to require any thing special as far as options go. It was configuration on the router that was causing the problem.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.