Clients not reporting correct connected device/port?

SOLVED
Kasking
Conversationalist

Clients not reporting correct connected device/port?

Using an MX68 GE connected to an MS220-8P in my lab.  Two APs, an MR42 connected to the MX68 and an MR32 connected to the MS220.

The problem I've noticed for a while is that in my client list, nearly all the wired hosts report that they are connected to the MS220 when in reality most are connected to the MX68 switch ports.

Upon close inspection they all seem to be connected to port 8 on the MS220 which happens to be the Interswitch Link between the MX68 and MS220.  So, I'm assuming I have some kind of bridging or STP issue.  Is there something I should check in the bridging configuration?  I've not changed much from the defaults.

 

thank you

1 ACCEPTED SOLUTION
cmr
Kind of a big deal
Kind of a big deal

@Kasking at the moment the MX LAN ports aren't treated like switch ports for monitoring, this is why all the devices attached to the MX LAN ports appear to be connected to the MS port that links to the MX.

 

There is work underway to improve on this so that the device plugged into the MX LAN port will show which port it is connected to on the MX, and so that you can see what devices are connected to each MX port, rather than just seeing that they are connected to the MX somewhere.

 

I don't have an exact timeline, but it is actively being worked on so I'd hope within a few months at most.

View solution in original post

8 REPLIES 8
UCcert
Kind of a big deal

Hi @Kasking , this could be down to the Client Tracking option you have selected on the MX?  Go to Security&SD-WAN,  Configure, Addressing and VLAN's and verify what option you have selected.  Try switching over to Unique Client Identifier.  Ignore what I have selected below....that was a quick screen scrape from my lab.

 

UCcert_0-1606947593873.png

 

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
Kasking
Conversationalist

I probably need to be on BETA software for that.  My only options are MAC and IP Address.

I have no non-Meraki devices in my network right now. And they are all on the same subnet.

AjitKumar
Head in the Cloud

Hi @Kasking 

I believe this option will appear only if we have a Meraki L3 Switch in our network.

 

How is the output when you select "only switch clients" under Network-Wide > Clients.

 

AjitKumar_1-1606964052877.png

 

 

 

Regards,
Ajit
AjitsNW@gmail.com
www.ajit.network
Kasking
Conversationalist

Thanks for your help.  When I select only switch clients the list is changed to a shorter list of most of my clients (21 of them), and they are all showing connected to my 8 port switch.  Its as if my MS220 is not switching, but acting like a repeater, therefore showing all the MACs from the MX as local.

 

does this make sense?

cmr
Kind of a big deal
Kind of a big deal

@Kasking at the moment the MX LAN ports aren't treated like switch ports for monitoring, this is why all the devices attached to the MX LAN ports appear to be connected to the MS port that links to the MX.

 

There is work underway to improve on this so that the device plugged into the MX LAN port will show which port it is connected to on the MX, and so that you can see what devices are connected to each MX port, rather than just seeing that they are connected to the MX somewhere.

 

I don't have an exact timeline, but it is actively being worked on so I'd hope within a few months at most.

View solution in original post

Kasking
Conversationalist

@cmr, I see.  Thank you for this info.

I would very much like to see these changes, it would be very helpful to be able to control the port configs in the MX just as the MS, and of course, to see the correct connected ports.

 

I'll look forward to this update.

mooselink
New here

Any update to this. I'm having the same issue.

Kasking
Conversationalist

Hi Mooselink.  Im now running MX 15.44 on my MX68 and still seeing inconsistencies with the device connection reported by the dashboard.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels