cancel
Showing results for 
Search instead for 
Did you mean: 

OID DevIntefaceEntry for MS in snmpv3 (Organization>Configure>Settings)

Highlighted
Comes here often

OID DevIntefaceEntry for MS in snmpv3 (Organization>Configure>Settings)

Hello,

 

I m trying to get response from snmpwalk for MS.

 

We can have a response from the OID '.1.3.6.1.4.1.29671.1.1.4' from devtable (for MS).

 

 Here is our request:

 

for i in $(seq 1 14) ; do echo -e "$i"; snmpwalk -v 3 -u 'user' -A 'password' -a SHA -X 'privacy password' -x AES n143.meraki.com:16100 -l authpriv  .1.3.6.1.4.1.29671.1.1.4.1.$i.$MAC -O n; done
1
.1.3.6.1.4.1.29671.1.1.4.1.1.MACAddress = Hex-STRING: MAC Address
2
.1.3.6.1.4.1.29671.1.1.4.1.2.MACAddress = STRING: "MS1 Name"
3
.1.3.6.1.4.1.29671.1.1.4.1.3.MACAddress = INTEGER: 1
4
.1.3.6.1.4.1.29671.1.1.4.1.4.MACAddress = Hex-STRING: MAC Address
5
.1.3.6.1.4.1.29671.1.1.4.1.5.MACAddress = INTEGER: 3
6
.1.3.6.1.4.1.29671.1.1.4.1.6.MACAddress = No Such Object available on this agent at this OID
7
.1.3.6.1.4.1.29671.1.1.4.1.7.MACAddress = IpAddress: A.B.C.D
8
.1.3.6.1.4.1.29671.1.1.4.1.8.MACAddress = STRING: "serial number"
9
.1.3.6.1.4.1.29671.1.1.4.1.9.MACAddress = STRING: "MS220-8P-HW"
10
.1.3.6.1.4.1.29671.1.1.4.1.10.MACAddress = STRING: "Meraki MS220-8P Cloud Managed PoE Switch"
11
.1.3.6.1.4.1.29671.1.1.4.1.11.MACAddress = STRING: "MS1 Name"
12
.1.3.6.1.4.1.29671.1.1.4.1.12.MACAddress = No Such Object available on this agent at this OID
13
.1.3.6.1.4.1.29671.1.1.4.1.13.MACAddress = No Such Object available on this agent at this OID
14
.1.3.6.1.4.1.29671.1.1.4.1.14.MACAddress = No Such Object available on this agent at this OID

 

 

Nevertheless, we can get feedback from all OIDs  '.1.3.6.1.4.1.29671.1.1.5.1' from devInterfaceTable for MS.

 

 

Here is our snmwalk:

 

snmpwalk -v 3 -u 'user' -A 'password' -a SHA -X 'privacy_password' -x AES n143.meraki.com:16100 -l authpriv  .1.3.6.1.4.1.29671.1.1.5.1 -O n | grep -i "MAC address"

.

.

.

 

These OID work with MX and MR but not with MS.

 

We configure snmpv3 through Organization>Configure>Settings.

 

Could you help me please?

 

Do you see something wrong with the snmpwalk ?

 

Regards