cancel
Showing results for 
Search instead for 
Did you mean: 

SMB Scanning Not Working Between VLANs on MX65W

Highlighted
Here to help

SMB Scanning Not Working Between VLANs on MX65W

One of our guys that's in charge of setting up our small offices reported that when they tried to scan from an OCE printer and send it to an SMB share, it doesn't work if the printer is on a different VLAN than the NAS device it's trying to send it to.  If they put the printers on the same VLAN as the NAS device, it works.  The are able to print to those printers when they're on a different VLAN though. 

 

All the VLANs are configured on the MX65W we have there.  We have a single MS120-24P that has a trunk port up to the MX65W with all VLANs allowed on the trunk. 

 

Printers were on VLAN 120 and NAS/Workstations were on VLAN 16.  The workstations on VLAN 16 could print to the printers on VLAN 120, but the scan from printers on VLAN 120 to SMB share on the NAS in VLAN 16 didn't work.

 

Once the printers were moved to VLAN 16, the scan function worked. 

 

I have no ACL's between VLANs.

 

Any ideas?

2 REPLIES
Kind of a big deal

Re: SMB Scanning Not Working Between VLANs on MX65W

I'm not an expert on how SMB works but many multicast style devices will only search the subnet they are in based on their subnet mask and gateway.  

 

Can you make it scan to a statically defined share instead of SMB?  

Adam R MS | CISSP, CISM, VCP, MCITP, CCNP, ITILv3, CMNO
If this was helpful click the Kudo button below
If my reply solved your issue, please mark it as a solution.
Building a reputation

Re: SMB Scanning Not Working Between VLANs on MX65W

I agree with Adam.  I would not expect that to work.  Printers and shares on a different VLAN need to be addressed directly by IP.