Problem with DHCP just after update MXes from 14.53 to 15.42.1

SOLVED
MichalM
Conversationalist

Problem with DHCP just after update MXes from 14.53 to 15.42.1

Hi, i have a problem with DHCP on all VLANs just after update MXes (to 250 in HA) from 14.53 to 15.42.1.

Both MXes were working as DHCP server in all VLANs and till the upgrade all was ok. Just after update, i got:

DHCP problem extra: no_offers_received, vap: 0, vlan: 248

Tried to restart MXes, disable/enable DHCP etc but without any results.

Finally helped downgrade.

 

Do you know what might be the reason? Is there a special configuration to be done after the upgrade?

 

1 ACCEPTED SOLUTION

Accepted Solutions
cmr
Kind of a big deal
Kind of a big deal

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

@MichalM it is in the 15.42.1, 15.42.2 and 15.42.3 release notes at the top under "Important Notice":

 

Important notice

  • Please note MX 15.41 and higher includes a change that resolved an issue that caused MX appliances to not source DHCP messages from the shared virtual MAC address when configured in High Availability (HA). DHCP messages from MX appliances configured in HA will now be sourced from the shared virtual MAC address.

Unfortunately it doesn't appear to have been added to the 15.41 or 15.42 release notes.

 

 @CarolineS could this be amended as the later versions indicate that the earlier ones have the same fix?

View solution in original post

5 REPLIES 5
PhilipDAth
Kind of a big deal

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

I haven't seen that issue, but we have a lot of our clients running 16.x now for the AnyConnect support.  We've had no issues with 16.x.

 

Perhaps try 15.43.

MichalM
Conversationalist

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

I found the next thing. Just after the update to 15.42 in every VLAN appears a new DHCP server which is not on the well-known DHCP list. Its MAC address has changed three first sections. The last three remains the same as MX Master.

Is it possible that the DHCP server changes its mac after the update?

 

MichalM
Conversationalist

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

Ok, i found the problem. Meraki in this update changes DHCP MAC address from appliances to vMAC from VRRP.

I couldn't find such info in changelog...

 

cmr
Kind of a big deal
Kind of a big deal

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

@MichalM it is in the 15.42.1, 15.42.2 and 15.42.3 release notes at the top under "Important Notice":

 

Important notice

  • Please note MX 15.41 and higher includes a change that resolved an issue that caused MX appliances to not source DHCP messages from the shared virtual MAC address when configured in High Availability (HA). DHCP messages from MX appliances configured in HA will now be sourced from the shared virtual MAC address.

Unfortunately it doesn't appear to have been added to the 15.41 or 15.42 release notes.

 

 @CarolineS could this be amended as the later versions indicate that the earlier ones have the same fix?

View solution in original post

MichalM
Conversationalist

Re: Problem with DHCP just after update MXes from 14.53 to 15.42.1

@cmrthanks for the explanation, somehow I did not found this info in the changelog.

 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels