cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Multiple Default routes on Branch MX is there a way to have only one ?

Highlighted
Here to help

Multiple Default routes on Branch MX is there a way to have only one ?

I have MX64 deployed as Spoke to an hub site with default route set to hub MX250, on the wan interface also i have Default route with next hop as the default gateway of the WAN interface.

 

Is there a way to ensure there is only one Default route on MX64 ?

Also customer complains that the LAn users on this branch node uses the default route over WAN interface to reach internet instead of going over to MX250 on the hub ?

 

Have any one seen this issue ? 

3 REPLIES 3
Highlighted
Kind of a big deal
Kind of a big deal

Re: Multiple Default routes on Branch MX is there a way to have only one ?

on your spoke @ site-to-site vpn settings

All your vlans are set to : vpn on?

and you selected the hub and set the default route option there?

Highlighted
Here to help

Re: Multiple Default routes on Branch MX is there a way to have only one ?

Yes, all vlans are set to VPN on.

Yes, default route option is selected for this particular hub.

Highlighted
Kind of a big deal

Re: Multiple Default routes on Branch MX is there a way to have only one ?

When you open up the route table for your Spoke/Branch and set it to Sort By: Priority as shown in the screenshot below.

 

Is the default route with the type Meraki VPN: VLAN, above the default WAN route? It should be.

 

Then, if it is, is the icon status showing a green circle? In my screenshot it's showing the revolving wheel icon which basically means that the needed tunnel is not yet established or not working, so it would fall back to the default WAN route.

 

If it is green then all packets should be routed over the VPN. If not we'll have to troubleshoot further.

image.png

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.