cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MX65 vlans not working

SOLVED
Here to help

MX65 vlans not working

I have a MS120 => to MX65 with vlans setup, when I set a port on the MS120 to an access or trunk, the computer is unable to contact the mx dhcp server and doesn't get an ip.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Head in the Cloud

Re: MX65 vlans not working

Hi @DPringle3 

 

I believe we are missing some configuration. Could you please recheck the following?

 

1. DHCP Server is enabled on the MX VLAN

    ->Security & SDWAN->DHCP->VLAN-> Client addressing

 

2. The Port connected between MX & MS120 is in "Trunk Mode"

    ->Security & SDWAN->Address & VLAN-> Per-port VLAN Settings

 

3. The Switch Port at MS120

   ->Switch->Switch ports->Switchport->Type=Access->VLAN= VLAN ID

 

Regards
Ajit
ajitsnw@gmail.com

View solution in original post

4 REPLIES 4
Highlighted
Head in the Cloud

Re: MX65 vlans not working

Hi @DPringle3 

 

I believe we are missing some configuration. Could you please recheck the following?

 

1. DHCP Server is enabled on the MX VLAN

    ->Security & SDWAN->DHCP->VLAN-> Client addressing

 

2. The Port connected between MX & MS120 is in "Trunk Mode"

    ->Security & SDWAN->Address & VLAN-> Per-port VLAN Settings

 

3. The Switch Port at MS120

   ->Switch->Switch ports->Switchport->Type=Access->VLAN= VLAN ID

 

Regards
Ajit
ajitsnw@gmail.com

View solution in original post

Highlighted
Here to help

Re: MX65 vlans not working

shouldn't I be able to ping the gateways of the other subnets, currently I am unable to.

Highlighted
Getting noticed

Re: MX65 vlans not working

definitely you will be. where are these gateways configured  on MX65 ? if not then you need to put the static route in your mx pointing towards other device in the same subnet that tells you the path to reach to other network. 

Highlighted
Getting noticed

Re: MX65 vlans not working

MS120 port should be in access when it is going to computer. MS120 is L2 switch so you have to define the VLAN in MX65 by going into 

 

Step 1: Security & SDWAN>Address & VLAN>  Add VLAN

 

Step 2: Now go to Security & SDWAN->Address & VLAN-> Per port VLAN setting and it should be trunk depend upon Native vlan you have configured like 1 or any

 

Step 3: Now configure the DHCP scope by Security & SDWAN>DHCP and run a DHCP server for selected vlan.

 

Now the MS120 part

 

Uplink to MX 65 will be trunk.

 

go to Switch> DHCP servers & ARP  and enter the MX65 mac address in Allowed DHCP servers box.

 

 

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.