MX64 dynamic host name

Here to help

MX64 dynamic host name

Dear Sir,


I cannot reach dynamic host name  for my device mx64.

My wan port ping is enable.


Thanks and regards


6 Replies 6
Kind of a big deal

What are you trying to do exactly? I that the name does resolve to an IP address so that part is working fine.


If you're trying to port forward something, make sure that any devices that are in front of the MX (e.g. ISP router) are also setup correctly to forward traffic to the MX, either through single port forwarding or by setting up the MX as DmZ device.


Also, some providers keep certain ports closed.


It's best not to post your actual Dynamic DNS name in a public forum.

Dear sir,


When I trying to connect the cilent vpn server for mx64, android built in vpn client giving error as :- unsuccessful.

Also when I trying to connect with Cisco Any connect for android client than it is giving error as :- your host name is unreachable. Although my MX64 is showing online. Also I am trying to ping the MX64 full host name from outside using internet it is giving error as :- request time out.


In my internet router I did forwarded port UDP 500 and UDP 4500 to the MX64 IP.


So it is look like outside world are not able to resolve the MX64 full host name.


Thanks and regards.


Meraki MX does not support AnyConnect.  You need to be using L2TP over IPSec.  You can find the instructions here: 


There is a trouble shooting guide here: 


Does you MX have a public IP on it, or is it sitting behind another device doing NAT?

@ehsan230564  Have you tried pinging and using the devices external IP rather than its hostname?



Okay so the IP address you pm'd me is the address that is actually resolved so that part is working fine.


You can't forward ping (icmp) as you do with regular ports. So the fact that you don't get ping response just means that your provider router is not responding to them.


Regarding the client VPN, the link that @PhilipDAth posted should help in the troubleshooting. Maybe you can test with a simple http server first. Also try to find out if your provider is known to block certain ports.

Dear Sir,


My MX64 is it sitting behind another device doing NAT.

And I configured the MX WAN IP as DMZ in Internet router.


Also I tried to connect with Android built in VPN client, and the error is : unsuccessfull


Thanks and regards.




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.