I currently have a Cisco 2811 setup at one of our branches. It has an MPLS and internet connection on the fastethernet interface using subinterfaces (one physical connection). I want to know if the MX can be setup in the same manner. It doesn't seem to have this feature on it for subinterfaces but I might be missing it. I have the router interface config and the static routes below, any advice would be helpful. IP's are just for example purposes.
interface FastEthernet0/0.300
description **INTERNET**
encapsulation dot1Q 300
ip address 21.21.21.106 255.255.255.252
ip access-group INTERNET in
ip nat outside
ip virtual-reassembly
end
interface FastEthernet0/0.200
description **MPLS**
encapsulation dot1Q 200
ip address 11.11.11.10 255.255.255.248
end
ip route 0.0.0.0 0.0.0.0 216.81.55.105<---Internet
ip route 10.0.0.0 255.0.0.0 100.64.1.9<---MPLS
ip route 172.16.0.0 255.240.0.0 100.64.1.9<---MPLS
ip route 192.168.0.0 255.255.0.0 100.64.1.9<---MPLS