Locked Firmware Upgrading Automatically and taking down network.

SOLVED
CharlieCrackle
Building a reputation

Locked Firmware Upgrading Automatically and taking down network.

I current have a bug in  meraki firmware in any version after 15.44     Case 08418471  Been told there are 100 other cases linked to this bug.

 

Support have locked the Firmware to 15.44  (and the dash board shows locked)

 

The issue is  meraki keep trying to  automatically upgrade and take the network down

 

Support tell me that even though the dashboard show new version it is still locked.  but I do not believable them as the network dies when the upgrade happens and works again when you roll back the upgrade. 

 

Why when the firmware is locked does the automatic firmware update keep trying to upgrade ?

 

Better still fix the bug !

 

1 ACCEPTED SOLUTION
Ryan_Miles
Meraki Employee
Meraki Employee

If firmware is locked or pinned on a device it will not change regardless of what the network is set to. A pinned device would simply ignore whatever the network is set to. It won't upgrade, reboot, etc.

 

I also see the full notes in the case. The issue you're running into is due to your spoke having 192.168.1.0/24 as the WAN subnet and you also have the same route available via an AutoVPN peer. The fix is either change your spoke subnet so it doesn't overlap. Or, upgrade to MX 18.

 

If it were me I'd just change the spoke WAN subnet to something non overlapping.

View solution in original post

5 REPLIES 5
alemabrahao
Kind of a big deal
Kind of a big deal

I believe it's best you call support directly and talk to them.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Ryan_Miles
Meraki Employee
Meraki Employee

If firmware is locked or pinned on a device it will not change regardless of what the network is set to. A pinned device would simply ignore whatever the network is set to. It won't upgrade, reboot, etc.

 

I also see the full notes in the case. The issue you're running into is due to your spoke having 192.168.1.0/24 as the WAN subnet and you also have the same route available via an AutoVPN peer. The fix is either change your spoke subnet so it doesn't overlap. Or, upgrade to MX 18.

 

If it were me I'd just change the spoke WAN subnet to something non overlapping.

ww
Kind of a big deal
Kind of a big deal

Where can we find this info regarding this kind of issues?

This not been my experience  and I have to roll back

 

I would love to change the spoke but Star-link  can only be configured to 192.168.1.0/24  and it cannot be changed.

Elon if you are reading can you please allow users of star-link to change the LAN addressing and turn off the WiFi  it would allow much better playing with meraki.   In Australia we have a lot of remote farms on star-link using Meraki

Elon Thank you.  

 

======================================

 

To bypass the router, go to the App home page > Settings > Advanced

Starlink App version must be at least 2.0.19 to work

The toggle button on to bypass the Starlink router

This allows you to completely disable the Starlink Wifi Router.

You would need to utilize a Starlink ethernet adapter in order to plug in your own equipment.

While Bypass mode is enabled, router commands will not work.

If the toggle switch does not appear in the Settings tab, can factory reset the router and/or delete and re-download the app.

App Message in red text when Bypass is enabled: "Bypass Mode will completely disable the built-in Starlink Wifi router. this is an advanced feature that requires a Starlink Ethernet adapter and your own network equipment. A manual Factory reset will be required to reverse this."

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels