Client VPN users connect to Play Station are getting disconnected

Here to help

Client VPN users connect to Play Station are getting disconnected



We have users' connected from Home PC to PlayStation via Client VPN and we are observing disconnection issue for them.


At first, we suspected the issue was from user's ISP, but during our remote session with multiple users, we observed all of the user(if not all, most of then faced it. Like 60-70% users) were getting disconnected (game pop-ups with message 'Trying to connect 1/5'), at the same time.


We tried to Whitelist the PS4 users along with VPN IPs were whitelisted, but still the issue persists.


It was observed that the user's download and upload speed was above 250Mbps(on online speedtest), while on use to give 75+(75 being Meraki's limit). The actual speed required for this game is not more than 50-60Mbps.


We have even upgrade the Firmware on MX250 to 15.40 version.


With the help of TAC, we tried to run iperf(bandwidth testing tool) and the output was fine(verified by Meraki TAC).



One more observation we came across was, we have same setup in different location with double bandwidth and triple users and the setup for both the location is same, but we are not facing any issue for other location.



We are at the end of troubleshooting ideas and issue still persists.


Any help from community will be appreciated.



4 Replies 4
Kind of a big deal
Kind of a big deal

What kind of traffic is being used from the PC to Playstation? Have you run a tcpdump on that? I'd guess we're dealing with a lot of small, fast-paced packets per second.

On PC the users have Remote Viewer application installed which is connected via client VPN to PlayStation(connected in office).


Due to that we are not able to view what kind of exact traffic is been sent.


But I think the type of traffic which is been sent is control commands from PlayStation keyboard/Joystick to PlayStation console and audio-video for viewing the game and sound.



Just for testing purpose, have added traffic shaping rule for PlayStation and Xbox LIVE with DSCP tagging = 10(AF11 - High Throughput, Latency Insensitive, Low Drop). I don't know whether this will work or not. If you have any other solution it will be appreciated.


Another observation was, the CPU utilization used to spike to almost 100%(as per Meraki TAC). Hence for time being we have disabled AMP, but still this hasn't resolved our issue, nor the Meraki TAC is able to point out the exact issue even after several packet captures, iperf, disabling IDS/IPS and AMP, firmware upgrade to latest version(15.40 was latest that time) etc.





Kind of a big deal
Kind of a big deal

Does the MX have a public IP address on it directly, or is it plugged into the back of something else doing NAT?


The most reliable configuration is to have the public IP address directly on the MX.

Meraki MX has a public IP address. So when the user is connected to the VPN, 'what is my IP' will give MX's IP address.




Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.