Thank you so much Philip!
I highly appreciate your input. This is what I was looking for! I was thinking if I should create a PortChannel with the new ports towards the MX or just use a single link. I will try the single link tomorrow.
Currently, the config of the ports towards the ASA are:
interface GigabitEthernet1/0/4
description #### ASA 5516-X MGMT PORT ####
switchport access vlan 250
switchport mode access
!
interface GigabitEthernet1/0/1
description #### ASA 5516-X PORT 4 - INSIDE INTERFACE ####
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet1/0/2
description #### ASA 5516-X PORT 5 - DMZ NETS ####
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1840-1855
switchport mode trunk
Will the new port towards the MX from the Catalyst look like this to make it work:
interface GigabitEthernet1/0/3
description #### MX84 PORT 8 - DMZ NETS ####
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1840-1855
switchport mode trunk
or
interface GigabitEthernet1/0/3
description #### MX84 PORT 8 - DMZ NETS ####
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all
switchport mode trunk
or
interface GigabitEthernet1/0/3
description #### MX84 PORT 8 - DMZ NETS ####
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 250, 1000, 1840-1855
switchport mode trunk