WPA-PSK auth fail Auth (RADIUS) under Heath Tab

Here to help

WPA-PSK auth fail Auth (RADIUS) under Heath Tab

I've seeing hundreds of errors 'WPA-PSK auth fail Auth (RADIUS)' under the heath tab.

The issues is happening across all of my AP's and across different hardware. Nothing has changed our side so not sure of the cause. All of the errors relate to different Apple hardware, iPads, iPhones, iMacs aside from one error showing the same error from a Sonos speaker. PSK's have not changed and the devices listed as having issues are still able to connect to wireless.


6 Replies 6
New here

I turned off Apples new Private WI-FI Address and Limit IP tracking features to see if that helped address this, I keep dropping connections on my Meraki Go WiFi!  

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Hi @PB83 and @LouisN5 


Thanks for taking the time to give us some feedback on the new Health tab in the app.


The WPA-PSK Auth fail does mean a client is failing to authenticate. At a technical level, and we will be publishing documentation on this, the event is generated when the WPA-PSK portion of the packet exchange fails.


A correct password that gets lost in some interference will get reported as a PSK failure, as the access point won't know any better. It is still worth investigating if happening frequently, but can be considered merely informational if the network is still operating normally.


All this being said, I definitely would open a support case with our team to make sure there is nothing out of line going on and that the reporting is indeed accurate.

I’m having this problem for the last week or so now as well. exact same issue, mostly Apple devices but also Ring cameras. It’s not the devices as they work 100% on other manufactures Wi-Fi kit. 


I don’t think we can consider it “informational” if the clients still don’t connect without manual intervention (airplane mode on/off for example), and Infrastructure Documentation isn’t helpful to users who get frequent Wi-Fi disconnects either. 

support case is opened anyway, but if Meraki-go can’t get this sorted out I’ll be moving away from it in the future, especially considering the Security Router has only one of those properties. 

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Hello @LuckyLionTamer 


Opening a support case is definitely the correct approach to get to the bottom of the problem. It would be interesting to execute a monitor mode capture while the clients are failing to connect, then again after performing the airplane mode sequence to get the clients back online. Comparing these two monitor mode captures would help elicit what exactly the client and access points are changing and finally allowing a connection.


I understand this may sound like a lot of effort to reach an answer, but it would certainly provide a strong foundation to draw conclusions from.

Found my own answer after support telling me “when you’re connected you have internet access” several times…. Just ignore the fact I can literally see the phone bouncing between 5g and wireless constantly when sitting in the same spot (full bars on Wi-Fi before you ask).


What’s actually happening is the APs are handing you off to another AP prematurely, causing this issue. I disabled the SSIDs on all but one of my APs and the issue went away (although creating signal issues in parts of the building as a consequence). 

I doubt I’ll be keeping this kit to be honest if Meraki don’t sort this out. I’m guessing it’s a bug in the latest firmware as it wasn’t an issue at all until a few weeks ago. 

Meraki Alumni (Retired)
Meraki Alumni (Retired)

I'm sorry for the experience you've had @LuckyLionTamer 

The ability to load balance incoming connections is not enabled on Meraki Go hardware. This means the decision to roam is a client initiated process, which is often dependent of the radio vendor used on the device (be it a smartphone, laptop, or otherwise). We don't push off client associations to other access points in the area.


I wonder if the apple devices are expecting the fast roaming feature 802.11r?

Get notified when there are additional replies to this discussion.