Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meraki Go GX20 “Reboot hardware” does not work

Here to help

Meraki Go GX20 “Reboot hardware” does not work

Hi everyone.


I have been using a Meraki Go GX20 for a couple of months now and it seems to be working well.


However, the "Reboot hardware" just does not work from the app. I have tried many things: reset hardware, uninstall/reinstall app, tried using app from different device, so on. Nothing fixes the problem. All I see is a kind of rotating beach ball and it never changes from that.






I have already been in contact with Meraki Support and they have run out of ideas.


Wifi on my home network is provided by a Ubiquiti AmpliFi in bridge mode. The GX20 provides the security to the internet. Other than the problem above, everything works great.


Has anyone had a similar problem? If so, how did you fix it please?



Meraki Go Team

Re: Meraki Go GX20 “Reboot hardware” does not work



That is certainly an interesting dilemma. Testing this out personally, I see the GX20 lights go out moments after issuing the command to reboot. I even tested with a VPN to simulate my connection from multiple regions throughout the world, to be sure.


The reboot command is effectively web traffic that is secured. Are you behind a splash page on your network, or somehow have network traffic restricted when using the Meraki Go app?


The rotating beach ball is the request sent to reboot waiting for the confirmation that the command was received. It seems like the command isn't reaching us.

Here to help

Re: Meraki Go GX20 “Reboot hardware” does not work

Thank you for the reply.


No, there is no splash page on the network and no network restrictions. The other two options: Test Connection and Blink LED work just fine.


I even swapped out the AmpliFi for an old Apple Airport Extreme (also in bridge mode). Exactly the same result as before. I just wonder if bridge mode would be the cause of the problem.



A model citizen

Re: Meraki Go GX20 “Reboot hardware” does not work

I´ve seen similar behaviour on my GX20 occasionally not constantly. Haven´t figured it out.

Here to help

Re: Meraki Go GX20 “Reboot hardware” does not work

Thank you for your reply.


I tried a few other things.


First I moved the GX20 to be behind the AmpliFi. So, the AmpliFi was the internet gateway. The Meraki Go app could see the GX20 on the network.

Result: Still no reboot.

Conclusion: Bridge mode is not the issue.


Second, my ISP provides some filtering capability that can be configured on the web. None of that appears to block Cisco traffic, but I temporarily disabled the filtering completely.

Result: Still no reboot.

Conclusion: ISP filtering is not the issue. However, I have contacted my ISP to check if any web sites or ports are blocked globally on their side.


Third, I notice that in the app there is Hostname assigned. It looks like this format:


<organization name>-appliance-<some kind of random characters>


I assume this is to handle Dynamic IPs.


Result: Trying to get to his web site fails. Correction: It loads the GX20 configuration page.

Conclusion: Not sure if I am meant to see the contents of this hyperlink. Correction: It loads the GX20 configuration page.