GO MX50 port forwarding issues

Here to help

GO MX50 port forwarding issues

Not sure if this is the correct board or not. If not please excuse and let mne kow where to post. 


I have a static IP address I am using as the up linkto by pass my comcast router. Internet access and network is functioning properly, excluding port forwarding. 


I have established two rule, followed the directions provided by the documentation and I am not getting forwarded. Have used online tewsting tools as well as the specific software on my computer to test. Have added my office IP address as an IP address to be allowed, assigned port(s) and designated the end device and have reserved its IP address.


Suggestions and guidance appreciated!



11 Replies 11
Meraki Employee
Meraki Employee

There is a dedicated Community for Go products here https://community.meraki.com/t5/Meraki-Go-Community/ct-p/go

Community Manager
Community Manager

I'll move this over into the Go community for you. Cheers!

Caroline S | Community Manager, Cisco Meraki
New to the community? Get started here

Thank you!

A model citizen

hello @Kit_ 


when you say by pass your comcast router, what does that mean?


Is the router set to act as modem, is the GX50 connected to a DMZ or did you just give it a static ip to connect to the router?


Could you provide the model name of the comcast router?



Giving the GX50 an up link (static IP address it by passes the Comcast Router's control, similar to the comcast modem/router being a bridge. The GX50 provides the DMZ services to the network. I don't have the name of the comcast router, sorry.



A model citizen

hard to say what causes your problem.


I run my GX at my workplace behind a router/modem I got from my ISP.


To run my own security gateway behind this router, it was required to activate IP-Passtrough on it. Means all incomming requests will be forwarded to port 1 on my ISP's router set with a specific IP-address. The GX had to be set to a static IP-address on the WAN-port. Now it handles all request comming from the internet as if there is no other device in between. The router functionality on my ISP's router is still working. I can connect devices directly to it and they get internet access.


At home I have a different ISP. This time the router had to be set to Bridge-Mode, this router acts just like a modem. The personal security gateway is set to optain a dynamic IP from my ISP. Here I can not plug in devices to my ISP's router to get internet access. They all have to be connected to my personal security gateway.


On both locations I have port forwarding rules set. They all work fine.


If you have a spare router somewhere laying around, you could hook that one up, instead of the GX50 and see if port forwarding will work. If it won't work, you might have a problem with the forwarding rules on your comcast router/modem.



Thank you Xydocq, I have the IP-Passthrough, its own specific static IP Address. All devices behind the GX50 have Internet. I do not know though about port 1 on ISP's router or if that is required.


I do not have anything else connected to the ISP's router, so if all else does not work I'll switch it to Bridge-Mode to see if that works.

I've tried both ideas and I'm still not there. My tech support has moved up to tier 3 now with comcast. If I can't get this to work then I'll be installing a different router with the hopes it won't have these problems. I appreciate your help!

A model citizen

You did follow the instruction as shown here: Port Forwarding on the Meraki Go Router Firewall - Cisco Meraki Documentation


the rule to forward port 80 http should look like that:




from what I learned, if you run different vlans, it's helpfull to select the vlan (the one the target device is on) under Networks before you set the rules.


Sometimes, it takes some time before a rule is applied to the GX. Especially the "ALLOWED PUBLIC IPS" can take up to 15 minutes to be active.


out of couriosity: what do you want to achieve with the port forwarding?


yes I followed the instructions verbatim. I have only one vlan and certainly have given the teh rules enough time to be applied.


My client has a programer that works on a server inside the network. instead of spending 2 hours in traffic we are setting up the forwards so he has unfettered access when he wants.


Certainly appreciate you time and help. I am soprry the GX50 didn't workout.

A model citizen

Why aren't you using VPN to have access?

Get notified when there are additional replies to this discussion.