Webclip profile won't install


Webclip profile won't install

When I update the profiles, my web clip profile (contains a singular web clip) gives an error saying - "Error: The profile "Webclip - Outlook" is invalid.


When I go to more details, I get:

Code: 1000

Domain: MCProfileErrorDomain


Error: The profile “Webclip - Outlook” is invalid.

Error: Empty profile

9 Replies 9
Kind of a big deal
Kind of a big deal

The "Privacy and Lock" payload setting modifies Dashboard-side configurations, rather than anything local to the device. If you create a profile with only this setting and attempt to push it to a device, the profile will fail to install with an Error: "The Profile is invalid." - In general, this error usually occurs when the profile has no settings configured in the profile.

The best practice for this setting is to nest it inside a profile that has other device settings. 



I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Kind of a big deal

You should be able to just push out a profile with a single web clip, I do it at several of my schools. 


The process is different depending on which devices you are pushing to though. What devices are you trying to push the web clip to?



Found this helpful? Give me some Kudos! (click on the little up-arrow below)

We are trying to push them out to iPads, 5th and 6th gen to be specific. I've selected the default application to be Safari, added an icon which is 144x144 in pixel size and haven't selected any of the tick options.


We are also using tags to try and push out the web clip. Created a tag named Webclip-'app-name' and assigned it to the required iPads. For the profile settings, it is set as, with ANY of the following tags.

I usually just leave mine blank. Here's a single webclip I push out to iPads for my district.




Found this helpful? Give me some Kudos! (click on the little up-arrow below)

Can you do a screen shot of your profile, and also a screen shot of the logs of the device/ That would be super helpful




Have you tried not specifying iOS and Safari? 


Honestly, I've never tried to force a webclip to open in Safari as it seems redundant to me as that's the default app on iPads.


That's the only difference I see in our web clip settings.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

I did try this but that still didn't work - I will raise a case like @PaulF said.

Have replicated your profile and it installed fine. If you've not done so, please raise a case, as I can't replicate this issue

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.