Samsung Gallery app not deploying

SOLVED
adambdc
Conversationalist

Samsung Gallery app not deploying

Since the upgrade to Android 11, I'm now running into a very annoying issue with trying to deploy the Samsung Gallery app for Galaxy S10e devices.

 

I'm able to add the app in the Cisco MDM Apps area, add it to a tag and deploy. However, when prompted to install the app, I get this error (see screenshot below): "Your device isn't compatible with this version."

 

Screenshot_20210419-120616_Google Play Store.jpg

The app just sticks in the "Managed Apps" area and shows up as requiring an install on the actual device page. No matter how many times I push a request to re-install, it continues to give the same error.

 

Screenshot_20210419-120607_Meraki SM.jpg

 

The only workaround I was able to do is deploy a similar "Gallery" app and then sync photo back ups to Google Photos for quick access. It's just very annoying. Is anyone else running into this problem?

1 ACCEPTED SOLUTION

Accepted Solutions
adambdc
Conversationalist

Re: Samsung Gallery app not deploying

@Shany 

 

Well, I'm quite dumb and still relatively new to Cisco MDM.

 

It turns out the device tag in my "Profile Configuration" under settings was completely removed. This was literally causing the issue with the Samsung S10e devices. The Gallery app now distributes perfectly with no problems.

 

Moral of the story: make sure all devices are on the correct policy and that the device tag is correct!

View solution in original post

4 REPLIES 4
Shany
Getting noticed

Re: Samsung Gallery app not deploying

@adambdc 

Looking at the link below, it doesn't seem to be a problem with Meraki SM.

https://docs.samsungknox.com/admin/knox-platform-for-enterprise/kbas/kba-369-cannot-install-samsung-...

It seems to be because the samsung gallery app is no longer available in the Google Play Store.

 

 

adambdc
Conversationalist

Re: Samsung Gallery app not deploying

@Shany

What's strange is if I reset the Samsung S10e device and bypass enrolling with Meraki SM, the app deploys perfectly fine and no issues arise trying to access it from within the camera app. The second I try to deploy it through Meraki SM, it fails.

 

I followed the doc link you provided and it suggested I whitelist "Samsung Gallery" in the Android Systems Apps area (System Manager > Settings). As you can see below, it's whitelisted and I'm still unable to deploy the app.

 

adambdc_0-1619188056956.png

adambdc
Conversationalist

Re: Samsung Gallery app not deploying

@Shany 

 

Well, I'm quite dumb and still relatively new to Cisco MDM.

 

It turns out the device tag in my "Profile Configuration" under settings was completely removed. This was literally causing the issue with the Samsung S10e devices. The Gallery app now distributes perfectly with no problems.

 

Moral of the story: make sure all devices are on the correct policy and that the device tag is correct!

View solution in original post

BettyJones
Conversationalist

Re: Samsung Gallery app not deploying


@Shany wrote:

@adambdc 

Looking at the link below, it doesn't seem to be a problem with Meraki SM.

https://docs.samsungknox.com/admin/knox-platform-for-enterprise/kbas/kba-369-cannot-install-samsung-...
Texas residents look for payday loans at https://cashloansnearby.com/texas/mckinney/, because most of the offers are collected there.

It seems to be because the samsung gallery app is no longer available in the Google Play Store.

 



Yes, everything works for me too, and indeed, it is very important to look at the device settings.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels