SM agent only running with admin user on Windows 10

Here to help

SM agent only running with admin user on Windows 10



I installed SM agent with admin credentials on a Windows 10 PC following the requirements. Unfortunately the PC is only used by a non-admin user all the time and SM agent doesn't work if admin user doesn't log in.


MerakiPCCAgent is running in the background successfully, so this admin access is not supposed to happen.


I receive the following message "The MDM user needs to log in to the device for settings to be updated" on the dashboard.


Has anybody received the same error?. Is there any workaround?.


Thank you.


2 Replies 2
Meraki Alumni (Retired)
Meraki Alumni (Retired)

Hey, @NitroGen 


Agent-based actions can be executed regardless of which user is logged in, however, for MDM commands, the user account used to enrolled in MDM must be logged into the device.


If you enrolled in MDM using the admin user, the best thing to do here would be unenroll under the admin user and re-enroll from the user account that will actually be using the device.


Otherwise, the current admin user that was used to enroll in MDM will have to be logged in so MDM commands can be executed.

Hello Victor, thank you for your answer.


For full enrollment, profile and agent need to be installed. The profile can't be connected to work or school with the regular user, because it mandatory need the administrator. 


So we tried to connect the pc using the admin account and then log in as the regular user and try to execute the agent installer with elevated privileges but it doesn't work anyway.


A case is opened with support but they say is a BUG and they are trying to see if there's a workaround.





Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.