SM Android app permissions get reset after reboot

Here to help

SM Android app permissions get reset after reboot

After we enable the permissions for the Meraki SM app shown in the app's "Alerts" section (see photo), the permissions get reset after a device reboot.

Device Model: SM-T638U
OS Version: Android 14
Meraki SM is in device owner mode.Screenshot 2024-06-07 153915 - Copy.png

3 Replies 3
Kind of a big deal
Kind of a big deal


Have you tried reinstalling the SM agent?
Also take a look at this.


I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.

Here are some potential solutions to resolve this issue:

  1. Check Device Policy: Since the device is in device owner mode, ensure that the device policy settings allow for the required permissions to persist after a reboot.

  2. Auto-grant Permissions: Some enterprise mobility management (EMM) solutions, like Meraki, have options to automatically grant permissions to certain apps. Make sure these settings are correctly configured.

  3. OEM Settings: Some OEMs might have additional settings or restrictions regarding permission management. Check if there are any Samsung-specific settings that might be causing this.

  4. Update Meraki SM App: Ensure you are using the latest version of the Meraki SM app. Sometimes, app updates include bug fixes for issues like this.

  5. Android 14 Compatibility: Since you are using Android 14, there might be compatibility issues with the Meraki SM app. Check for any known issues or updates from Meraki regarding Android 14 compatibility.

  6. Re-provision Device: As a last resort, re-provisioning the device might help in resetting any configurations that might be causing the issue.

To provide more specific guidance, I would need additional details, such as:

  • Whether this issue is occurring on multiple devices or just a single device.
  • If there are any custom configurations or policies applied to the device that might affect permissions.
Here to help

The solution was that the device has to be rebooted via holding the power button instead of just unplugging the power cable (device has no battery inserted).

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.