Meraki ios -Cant email photos while device is Supervised.

Here to help

Meraki ios -Cant email photos while device is Supervised.

Unable to email photos through the camera roll on the iphone. At first when trying to email a photo the email option was there but when you clicked on it, it would ask you to setup an email account. So we went into our meraki dep profile and unchecked the box for Use only in mail. When we did this the mail icon disappeared. How can we fix it so we can email photo's from the camera roll


Kind of a big deal

@Unknown  have you got an email account setup on the device. Can you install the Gmail app and use that?

Meraki CMNO, Ruckus WISE, Sonicwall CSSA, Allied Telesis CASE & CAI

Email account is pushed through meraki.Using gmail app wouldn't work as we use it for exchange

Here to help

Any updates for this?  We use this function repeatedly throughout the day and since deployment I cannot get the ipad to realize that a exchange profile is already on the device.  When I try to send a picture from photos, it asks to setup an email account as if it does not recognize the exchange profile is already installed?


For troubleshooting I added a gmail account, and then it works fine using the gmail account.  If I remove the gmail account the same behavior exists where it seems to not realize an exhange account is added?  I put in a support ticket 2 days ago and have yet to hear anything back.  

Yes, i was able to resolve this by unchecking use only in mail and checking the following boxes under apple restrictions.


After making this change and syncing, I went back in and now it does not show mail as an option when I click the share icon on a photo.  It shows message, airdrop, books etc, but no mail icon even when I click on the more button?


So appreciate everyones help.

Sorry, the correct ones that need to be unchecked are shown below 


Before I make this setting change, should I leave these settings unchecked as well as you stated previously?


After making these setting changes I had to re-enter exchange password on all devices, but still don't have the mail option now after selecting share on a photo.  

Is anyone else able to assist or have any ideas?  Meraki support team responded to the ticket stating this is something I cannot do.  😞


Obviously this is a usable function if others are able to use.  Hoping someone can have some insight as I am really disappointed with Meraki support at this time.  Hoping they will escalate and get back to me, but in the mean time hoping someone here has some insight.  



We should still be able to send pictures through mail on iOS, correct? I suspect there is a settings issue causing the problem here.


Can you possibly assist?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Head in the Cloud



Looking at these settings I would think these would need to be checked.




Have you tried checking these two boxes? I am assuming these are not managed email accounts but managed Apps so they would need to be checked.


Also, which iOS are you using on the device as I know Apple has made some changes there as well that are dependant on iOS version.





Found this helpful? Give me some Kudos! (click on the little up-arrow below)

We are currently on version ios 13.1.2.  


@vassallon I currently have the following boxes settings changes based on the recommendation of @Unknown ...


Unchecked ...



and have not changed these settings, so all remain unchecked...



I also have "use only in mail" currently unchecked.  


Appreciate the help, currently having a colleague on a non managed device update the ios to confirm that is not the issue.  



Okay, iOS 13.1.2. With this being the new iOS you will be affected by the new security rules put into place by Apple with iOS 13.


Have you tried with all 4 boxes checked?


I suspect with the new security Apple has released you might be in a unique situation. That's why I'm hoping Noah will chime in. 

Found this helpful? Give me some Kudos! (click on the little up-arrow below)



I did just have a colleague who is on a non managed device we have not enrolled yet just download ios 13.1.2 and confirmed she can still email from camera roll.  So the updated ios itself doesn't seem to be issue, but updated ios with Meraki I could see as an issue.  In another hour the work day will be over and I can make some setting changes, I will try checking all four boxes and see if that helps.


Appreciate your help so much, thanks for your time.  

@Locatetech It's not a problem at all.


I just know that sometimes big iOS updates don't always play as expected which is why I was hoping @Noah_Salzman might pop in to answer if it is working as expected with Meraki.


I do still think it is likely some combo of the check boxes blocking mail and photos from interacting.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

With all 4 boxes checked, same issue, does not show mail as an option and does not allow me to attach a picture in the body of the email. 


The exchange account is not a managed app, as I have nothing with exchange in my managed apps, however it is part of the profile being pushed. 


I then rechecked use only in mail, and I can now see email again as an option, but when I select it again cannot correlate it with an account already established on the device and wants me to setup a new account.  Basically like the ipad cannot "see" the exchange account profile from camera roll.  


I removed my ipad from the standard profile we have setup for everyone, and added my exchange account manually and even though my device is being managed, this gives me full functionality from the camera roll as well as insert attachment from email.  


The fault then lies in the profile we have setup for these accounts.  Not sure at this point if it would be easier to remove the exchange push completely and setup manually as I have less than 50 devices at this point?  






Mine is still working. i will attach screenshots tomorrow of all my restrictions and mail profile in meraki tomorrow 

Just tested with ios 13 and still works. here are my settings meraki mail settings.JPGrestrictions1.JPGrestrictions2.JPGrestrictions3.JPGrestrictions4.JPGrestrictions5.JPGrestrictions6.JPGrestrictions7.JPG

Comes here often

Up : 


I have the same issue, 


When, I add manually the settings for mailbox when prompt.


I have the mailbox icon with the possibility to send photo.



FYI - A good method for testing whether configuration issues you are seeing on Apple devices are caused by SM or Apple's OS, is to isolate the MDM factor.  


Step 1:
Unenroll your device and try installing the exact same profile configurations via Apple Configurator.  If the issue remains then you know that there is either a problem with your configuration, or an issue with iOS/macOS/tvOS.


Step 2:

If the issue does not persist, export the configuration from Apple Configurator.  Re-enroll your device into SM and deliver the configuration profile as a custom Apple payload. If the issue remains, then you are likely looking at an issue with SM - Call Meraki Support.


Step 3:

If the issue does not persist, double-check that the settings in your original SM profile(s) match the settings you created in Apple Configurator.  If you have confirmed a match, then the issue is likely in SM - Call Meraki Support.



The issue with this is that not everyone has a MacOS computer available to use Apple Configurator.


I'm also having this same issue on a significant number of devices and am going through trying the various solutions people have mentioned here. We're mostly on iOS13.3.3.1 and now iOS13.4 as of this afternoon and the issues are persisting: When I select either an image (from the Photos app) or a scanned document (from the Notes app) and select Mail, I'm presented with choices to configure an email account and not allowed to use the existing Exchange account configured by Meraki MDM.

Here to help

I've reviewed the thread and tried the various resolutions with no success.


Has anyone been able to resolve this?

The issue never resolved for us so long as we were using the Mail app and had Exchange accounts configured via Meraki.


We tried each of the solutions people in here proposed to no effect.


Any Exchange accounts that were manually configured on the phones could send email, but not Meraki-pushed accounts.


The issue resolved for us when we moved off of the Mail app to the Outlook app for mail. Once Outlook was configured, we were once again able to send images and scanned PDFs (from the Notes app) using the phone's default Share function.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.