Issue pushing app to managed device


Issue pushing app to managed device

Hi, we're attempted to update/install an app to a managed device but are getting the follow error under the 'Activity Log' section:

Code: 1005
Domain: DeviceManagement.error


Error: Could not install app.
Error: Purchase Batch Failed

We're trying to see what happened, and how to fix this remotely as this device is currently in the field, and was working on deployment for installing and updating. 
5 Replies 5
Kind of a big deal
Kind of a big deal

@PatCTaylor Have you recently pruchased this app? Have you been able to deploy this app on other devices?

Hey Blake,

This is happening with 3 free apps.
And yes, the app was deployed today to other devices, updated on some other devices from an older version (which is what we're doing here, updating these 3 free apps to the latest version), and we can even uninstall and reinstall on other devices (but not this device) 

Here to help

I’m getting the same error code and for example WhatsApp is showing 50/50 licenses available, even though we have it installed on devices. I did a forced VPP sync and still no dice, verified the push certs etc are still within date and they have plenty of time left. At this point I cannot upgrade apps on phones that have apps installed and are out of date. What could be causing this?


have you had any luck with this? I'm getting the same response with an app also.


Same with my apps. Seems to be problem with my iOS 14.4.2 devices. App still pushes with iOS 13 and below. Any answers yet?

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.