Device Enrolment Error: Leovo Tab 4

New here

Device Enrolment Error: Leovo Tab 4

I am trying to set up MDM for a bunch of Lenovo Tab 4's running Android 7.1.1 
I have added my @gmail account to a Meraki Managed, Android for work account but I can't enroll my device. 
1. I've tried a factory reset then entering 'afw#meraki' at the google sign in page but it says: 'Couldn't find your Google Account' 
2. I've downloaded the Meraki SM app from the Play store and selected Meraki Managed, entered the enrollment code, then it asks for 'Authentication Required' 
- I've tried my @gmail account details and I've tried my Meraki login details but both return this error: 'Incorrect username/password combination or invalid account added.' 
Any advice that could point me in the right direction would be great! 

Kind of a big deal
Kind of a big deal

Some varieties of Android don't support Android for Work natively, and it seems this is one of those devices.


It might work using ADB:

i just got these tablets as well and ran into the same issue and followed those direction and here is what happened to me


C:\Users\******\Downloads\platform-tools_r28.0.1-windows\platform-tools>adb shell dpm set-device-owner .DeviceAdmin
usage: dpm [subcommand] [options]
usage: dpm set-active-admin [ --user <USER_ID> | current ] <COMPONENT>
usage: dpm set-device-owner [ --user <USER_ID> | current *EXPERIMENTAL* ] [ --name <NAME> ] <COMPONENT>
usage: dpm set-profile-owner [ --user <USER_ID> | current ] [ --name <NAME> ] <COMPONENT>
usage: dpm remove-active-admin [ --user <USER_ID> | current ] [ --name <NAME> ] <COMPONENT>

dpm set-active-admin: Sets the given component as active admin for an existing user.

dpm set-device-owner: Sets the given component as active admin, and its package as device owner.

dpm set-profile-owner: Sets the given component as active admin and profile owner for an existing user.

dpm remove-active-admin: Disables an active admin, the admin must have declared android:testOnly in the application in its manifest. This will also remove device and profile owners

Error: Invalid component

C:\Users\*******\Downloads\platform-tools_r28.0.1-windows\platform-tools>adb shell dpm set-device-owner .DeviceAdmin



I sent in a Help Case to see what the correct thing to do here is

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.