Custom app not installing

Just browsing

Custom app not installing

Hi, We have a custom APK we're trying to load (device owner). The app never appears (identifier is correct), either auto-pushed or through self-service.

Think it way be due to APK size - it's 1.4GB. Tried with another app (22MB) and that loaded just fine. Is there an APK file size limit?

4 Replies 4
Getting noticed


The APK file that does not install is a problem with Android Version compatibility, or App packaging may not be able to have a good fit.

When installing an APK on a device that uses a low Android Version, was able to see 'Success' in SM dashboard, but it has often experienced that it is not installed on the device.

It seems to be a way to manually install the missing app by running the SM installed on the device.


Or, after pushing the APP on the device in the SM, you should have a client side debugging as described in the link below.


A few points:

- The device is running Android 10, so a recent version

- A similar app built by us (but significantly smaller in size) loads fine

- trying to manually install the app via self service in SM shows 'downloading' toast , then nothing

- I have tried debugging via USB, but nothing useful in the log.



The _only_ thing that works is loading over USB via ABD, then Meraki seems to pick it up, but this is not ideal.

What about installing apps using WebClip?

If you can not install it using WebClip, we will be able to suspect APK or Android APK file size limitation or else.

Getting noticed

Hey @onebillion , did you ever get a resolution on this? I'm curious as I've got a buddy hitting a similar issue on their MDM solution with an .apk I helped put together. 


Thanks a bunch!


Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.