Apps not showing on iPads


Apps not showing on iPads

I have certain apps set up to download on all new devices that are attached to my organization.  According to the settings in my ipads, the apps have downloaded, however there was no icon created on the home screen so I can't find it to open the app.  The whole point of using the MDM is so we don't have to manually download and change things on every device - how am I supposed to access these apps after they download?


Im having the same issue with my devices. if you try to erase them and reload them. it works.  However after having 20 of them in front of me with the same issue i have seen some of the other apps go missing afterwards.  I tried to do a selective wipe from the console and that didnt solve the problem. i tried updating the ios to the latest version to see if that corrected still no change.

Head in the Cloud

I have seen a few things cause this to occur. Do you have caching servers in Place? What about firewall or content filter? Improperly configured caching servers and/or firewall/content filters can cause apps to either not load or be delayed in loading. 


What model of devices and iOS are we talking about having issues? Are you pushing free or paid apps? Are you pushing Apps based on serial numbers, tags or something else?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

The apps ARE loading - I can find them in the Settings.  I just can't find the app icon itself to open the program.


They are 5th Gen iPads with the updated iOS.


We currently only have 3 iPads, so we haven't done anything with tags.

Are these apps from the app store or enterprise apps? I haven't seen any issues with 5th gen iPads updated to iOS 11.3 not receiving Apps correctly. Also are you using the free or paid version of Meraki?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

They are from the App Store, and I am using the paid version of Meraki.

Which Apps are you pushing? I'd like to see if I can recreate the issue with my devices here. If you don't mind posting a screenshot of how you are setting up the Apps to push that could also be a clue to help us troubleshoot with you.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Kind of a big deal

I have not seen this issue. In addition to what others are seeing, are your devices possibly getting a whitelist/blacklist caused by a security policy? This would cause apps to disappear.

Find this helpful? Click the kudos button. Thanks!

We haven't set up any security or blacklisting yet.


we have no blacklist set up.  also when i erase the device and reload it.  it the  app comes back.  still dont know why  it does it though. since i have to do this for multiple devices. 

New here

I also had this issue and found that the solution was in the default restriction for "Apps" was set to do not allow "Apps".  Once I set this to allow all apps, it would allow me to see all of the apps that I had forced to install.

Meraki Alumni (Retired)

I'm late to this thread, but good catch @Jason_B!!


This is under "Allowed Content Ratings" on the Systems Manager >Settings page under "iOS and macOS Restrictions"

Screen Shot 2018-06-04 at 3.31.55 PM.png

Is there a way to set an app restriction, say to 9+ apps, but still allow some apps that are higher. Some kind of whitelist feature or something?

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.