Apple Automated Device Enrollment

Here to help

Apple Automated Device Enrollment

I have over 100 iPads that have been factory reset.


I have re-enrolled them with Meraki.


I have assigned them correctly to settings from the network.


I have tagged them appropriately.


They are STILL showing Assigned and NOT Pushed.


What am I missing?

Meraki Employee
Meraki Employee

Hey @JT5 ,


It'll go to "Pushed" when you start going through the iPad Setup process and the device connects to WiFi to check-in with Apple. Have you tried going through the setup process on a device that's currently in the "assigned" state?

Thanks for the reply ConnorL!


Yes, I have gone through the setup process on a device that is currently in the Assigned state.


Meraki support did reach back out to say: 


"There is a possibility that these devices may be in a state that they are not fully enrolled into ADE yet. Devices can be manually added to ADE via apple configurator which will cause a 30 day provisional period to begin (this time begins the day that the device is enrolled into an MDM solution after manually adding the device to ADE)."


But the iPads were enrolled weeks ago so that 30 day period has passed. The reason for the timeframe was because I've been working with over 500 devices. Meraki does say Verified on each iPad and I do see them under the ADE.


It's interesting. Some are Pushed, others are Assigned.

Kind of a big deal



The only time I see this is if a device has either not been setup since I assign the settings or I assigned new settings but the device has not been reset yet.


The only way the ADE settings can be applied to the device is on a factory reset. Can you try that with one of the devices you are having issues with and see if the status changes?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)

Thanks for the reply vassallon!


Yeah, while I haven’t tried this yet I’m thinking that even though there are iPads that have already been factory reset and Meraki re-enrolled it sounds like each device will need to be factory reset and the process of enrolling Meraki will need to be done again. 

I haven’t found a way to factory reset each iPad without physically touching it so with about 100 iPads that state Assigned……


*cracks knuckles*

Here we go, LOL.

Kind of a big deal



Do you not get the option in the devices page under command? 




This should allow you to select multiple devices and erase them at once.


Found this helpful? Give me some Kudos! (click on the little up-arrow below)

See, that’s the thing.


Even if the current iPads were Assigned or not I don’t have a way to communicate with them especially for a factory reset command.


Does that make sense?

Kind of a big deal

Ahhh okay, I think I understand what is going on right now.


Let me see if I correctly understand though.


You set them up once to get them enrolled into Meraki and then reset them to trigger the count down. 


These iPads are currently factory reset and waiting to be set up again. Though when you set one up from this state it isn't changing from Assigned to Pushed, if it's been more than 30 days it "should" push out the profile.


I also assume you are not using Apple Business Manager or Apple School Manager for managing your iPads as this changes how the iPads interact with Meraki through ADE. I use ASM so our devices are automatically assigned to us when we purchase them from Apple, this makes things so much easier than having to go through the claim process.


Are these iPads on a specific iPadOS or have you not see this make a difference for your troubleshooting?


I would definitely try one iPad and see if setting it up, resetting and then setting it up again changes the status.



Found this helpful? Give me some Kudos! (click on the little up-arrow below)

Great stuff vassallon, thanks for all the replies!


Correct on the first point.


The second point: 


Actually, I do use Apple School Manager. After talking to an Apple technical support representative I’ve done everything correctly up this point between Apple and Meraki.


And yes, I am working with iPads that range from 2014-2022. Now, the iPads in question, the ones Assigned, are mostly 2014-2016 range which means they fall under iOS. 

Yep, I think it’s just gonna be a long journey of tinkering with them starting with just one and see where that goes.

Kind of a big deal

Good luck, those older iPads that aren't updating could be very challenging as they won't necessarily play nice with the updates that have been made that require the latest versions of iPadOS.


Yeah using ASM is wonderful for not having to wait the 30 days for them to be assigned to you but if the devices are purchased from somewhere other than Apple you may still need to wait.


Theoretically the older devices should work and register into Meraki. I know that I've had some older iPad Air and Air 2s that registered into ADE correctly as of 2022 but we've retired most of those older iPads to make sure they run the current iPadOS as a minimum to stay in service.


If you've ever got any questions feel free to ping me as I've been using Meraki for iPad management since 2014.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.