Android apps disappearing - Need reapproval


Android apps disappearing - Need reapproval



We have some android apps that disappear from the devices on a fairly regular basis.  We've taken to unapproving and reapproving the affected apps from the app details screen in the dashboard.  When we do this, the app reappears on the device, seemingly with no loss of data.


Has this happened to anyone else, and have you found a way to stop this behaviour?  We have an open case with the support desk which has been referred to the Dev team for investigation.




10 Replies 10
Kind of a big deal
Kind of a big deal

I have not seen that issue.

Meraki Alumni (Retired)
Meraki Alumni (Retired)

We fixed an issue earlier this week that might be causing what you have been experiencing. Please 1) open a case and 2) tag me in this thread if you see this occur again. 

Hi @Noah_Salzman 


We appear to be experiencing a similar issue to what is described with several apps.


I've needed to reapprove Cisco Jabber around once or twice an hour since yesterday morning.


Also, yesterday I deleted a number of apps from Systems Manager which then spontaneously reappeared.


Nothing is showing in the Change Log or Event Log.


We have a case 05618146 open for this.

Meraki Alumni (Retired)
Meraki Alumni (Retired)

The fix in question went out last night (Tuesday) Pacific time. So it would not be surprising if you saw issues earlier in the day. Please @ me here if it is not resolved.

Hi @Noah_Salzman ,


We just lost approval on Cisco Jabber again in the last 15-20 minutes.

Hi @Noah_Salzman ,


I hit "Sync Android Enterprise apps" after my last reply which reapproved Cisco Jabber.


We have now lost approval on Cisco Jabber again.

Hi @Noah_Salzman ,


We're still seeing issues with some of our apps here.  We have a case 05493178 open with support.


I have tried syncing enterprise apps which worked for a while, but the affected apps reverted to unapproved.


On our network RingCentral and Mimecast are two of the affected apps available from the play store, with another that is distributed using targetted distribution from Play store.

Meraki Alumni (Retired)
Meraki Alumni (Retired)

Hi, @lord_tosswomble ! 


Thanks for bringing this to our attention.


Our engineering team has found the source of the issue, and deployed a fix yesterday that should prevent future loss of app approval, as well as fix and properly revert the approval state of un-approved apps back to "Approved" in Dashboard.


There might be some limited edge cases where you'll need to re-approve an app one last time, but they should not lose their approval state again unless the app is removed from the app store by the publisher, or "All future permissions" are not granted for the app and its permission list changes.


Please let us know if you continue to face any issues!




Thanks @VictorM 


No issues reported over the weekend, so I think it's all looking good now.


If there is anything I'll reopen our case and report back.


Thanks again



Hi @VictorM,


This is now looking resolved for us also.


Thank you for getting this fixed!

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.