Android System Apps

Samclark01
New here

Android System Apps

Hi,

 

We're having an issue whereby we are enrolling devices (mobile phones) as the device owner into Meraki SM.

 

I have set a policy up to allow the android system apps (phone, messages etc) as staff will need these - by blacklisting no apps and also tried whitelisting all apps - but neither seem to work. I have followed the meraki documentation but it still doesn't work.

 

Anyone had this? or know how to fix it?

 

Our users are now basically unable to use their work mobiles.

 

Thanks in advance for any help/advice.

 

 

1 REPLY 1
PaulF
Meraki Employee

Hi

 

One of the biggest problems with Android Enterprise in this use case is actually knowing what the identifiers actually are of the preinstalled apps

 

This can be achieved using adb and the following command:

 

adb shell pm list packages | awk -F ":" '{print $2}'

 

Once you've got the list of apps, you can then use the Android System Apps payload:

 

Screen Shot 2021-06-29 at 4.52.56 PM.png 

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels