Unable to create Webhooks - how can I tell WHY it failed?

Comes here often

Unable to create Webhooks - how can I tell WHY it failed?

I'm using Network-wide -> Alerts and attempting to add a test Webhook receiver.  I'm using webhook.site as the receiver for testing purposes, so there's no authorization or shared secret or anything else.  The payload template is the default Meraki template.  On every network I've tested, "send test webhook" says simply "failed".  There's no information that I can find about _what_ failed or how to fix it.


Some of the networks do have a Webhook receiver configured already, and some do not.  It doesn't matter which one I'm trying to add to.  I only mention it as evidence that someone was able to add them successfully at some point, just not me.

4 Replies 4
Kind of a big deal
Kind of a big deal

The error message does not provide much information, but maybe one of these discussions can help you.



Unable to configure webhook on alerts page - The Meraki Community


Solved: Meraki Webhooks don't seem to be triggering? - The Meraki Community


Solved: "send test webhook" failing to Slack - The Meraki Community

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
Meraki Employee
Meraki Employee

I just tested and it's working for me. All I did was add a new webhook receiver, copy the URL from the webhook.site page. Doesn't even require me saving the page on the Meraki side for the test button to work.


Screenshot 2024-02-01 at 07.06.11.png



Screenshot 2024-02-01 at 07.06.18.png

Ryan / Meraki SE

If you found this post helpful, please give it Kudos. If my answer solved your problem click Accept as Solution so others can benefit from it.

Is there a way to get any information about the test out of Meraki?  A simple "Failed" tells me nothing at all.

I found the API endpoints for creating Webhooks.  Attempting to create them via API resulted in 403 (Forbidden), which is at least something to investigate.  The UI didn't even tell me that.

Getting noticed

Sorry, went over your post to fast. The bellow prob. Wont work for you.


Had this one before. If the network you are trying to create a webhook in is a combined network, try spliting said network. Then you go through each component network and delete all mentiones of webhooks, recombine and try to add the config again.


This does not impact the network in any way.

Get notified when there are additional replies to this discussion.