cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

problems when installing missing applications on an android device SM meraki

Highlighted
Conversationalist

problems when installing missing applications on an android device SM meraki

I am enrolling a device to the "system manager" everything is done well however when installing certain applications, the device does not install them and the play store of google says that device owner does not and does not allow me to install those applications, but other devices in the same system manager say device owner if and profile managed and not work perfectly could you help me?

 

 

24 REPLIES 24
Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

We're having this same issue and we are actively working with support but not getting very far. Not sure how widespread it is or if its just a few customers. This is preventing us from deploying new apps and mobile devices, going on 4 weeks now. For us, ALL apps appear to be affected. Existing devices with existing deployed apps are working fine and updating fine, we just cannot push any newly requested apps to them. 

 

We're also using owner mode with a Meraki managed Android for Work domain. When we log into the gmail account tied to this we can see the apps and they are approved. We have tried removing the apps from there and re-approving them from SM. They re-show up in the gmail account's list but still do not deploy to tablets/mobile devices. 

 

We have also tried removing the tags for some time and re-adding them, this has also not worked.

 

SM shows that the app was successfully installed, but it wasn't. On the device end we see the following errors:

 

"There are no apps to install, since your administrator hasn't made any available to you yet."

 

"Your administrator has not given you access to this item."

 

Were you ever able to resolve this issue? 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

hello 

same issue for us 

Android devices, in AFW mode 

impossible to push apps on a lot of devices, apps are in scope, already approved... but still an error message on the device  : "Your administrator has not given you access to this item."

 

 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

Is there any people from Meraki on this community ? 

I have two case numbers about this issue, on two different system manager 

really need to have information about that issue ..

Highlighted
New here

Re: problems when installing missing applications on an android device SM meraki

Hey!

 

So I believe I had the same issue with this.

 

How did you enroll your device? AFW?

 

I tried the first way (using afw#meraki) and I got the same issue.

 

When I reset and tried it the second way (tap 6 times, scan QR code) it all went through soothly for me.

 

This was on a Samsung A3, Android 7.

 

Might be something to go off?

 

Karl

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

it seems there is an issue on the backend, 

but my case is open since 18th may....

 

i enroll using AFW, not owner mode 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

We'll try the second way (tap 6 times, scan QR code) and see how it goes. This did not work for us last week or the week prior but maybe they have been working on it and recent changes have resolved that. 

 

We did get some better news on Friday from our support rep, "There has been progress from our engineering team on this issue but we do not have an ETA on the resolution yet."

 

Our case is still active and we have requested daily updates, which we have been getting. They have not provided much beyond "Engineering is still working on it.". Per our support rep it is a larger issue going on and definitely with the back-end. 

 

Once my techs have tried the QR code route we'll report back on if that worked for us or not. 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

"tap 6 times + QR code" is it for owner mode ? or for AFW ? 

 

mid- may, it was working fine on about 50% of devices, but since 1 week, almost 80% of devices can't install apps push by system manager 

always the same message "your admin did not allow .... "

 

i have try on 2 different organisation , with 3 different devices brand (WIKO / Samsung / Huawei) 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

Tap 6 times, scan QR code also did not work for us, same errors in Google Play as the afw#meraki setup for v6.

 

However, re-approving each app in SM and then going to the app list and selecting Accounts -> Sync AfW apps did work and now apps are pushing to my stack of waiting tablets. We are no longer seeing the error in the Google Play store. 

 

Something changed because as of Friday this did not work when we tried it multiple times with support. 

 

Since there is very little info on this from Meraki, YMMV. 

 

Hope it works for you. 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

support is working on it, but not estimation time / date for resolution... 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

Same here. It was working yesterday and we were able to deploy some tablets and apps. Today it appears to be broken again.

Highlighted
Conversationalist

Re: problems when installing missing applications on an android device SM meraki

Hi all, we are having issues deploying Android apps today. We have 15 'default' apps that are rolled out via an AFW managed profile. Some install and then some only sit within systems manager saying not installed. Is this the problem that has already been reported? We didn't have any this problem on Tuesday and set 2 phones up no problem. Today 6 phones won't pull down all the apps. 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

If you click Install from within the SM app it should bring you to the Google Play Store. From there, it will likely say: "Your administrator has not given you access to this item." If so, its the same issue. 

 

They are definitely working on it as this issue has been very sporadic for us recently whereas before it was not working for a solid 4 weeks straight. When we get a window of it working we quickly deploy our mobile devices before that window closes and its no longer working again. The only way we find that window is by using a test tablet to constantly try deployments to see if its working again or not. Very frustrating. 

 

If you haven't, create a support case to help provide a sense of urgency on this. Going on six weeks now for us, possibly longer. Not sure what the overall issue is as Meraki has been very tight lipped on specifics. 

Highlighted
Conversationalist

Re: problems when installing missing applications on an android device SM meraki

We have had that issue, but this time the apps just arent installing and you have to either try and push them back out by Systems Manager or from the MDM app on the device - but its not always the same apps that don't deploy. I have logged a support call, so will see what happens. 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

we have a solution (short term) 

if you affect a owner before you activating the AFW account (warning indicator to green indicator) you will be able to install apps without error message 

 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

Same problem here.

No way to push apps on a AFW device in Owner mode.

LinkedIn works but Outlook doesn't.

Same errors.

Highlighted
New here

Re: problems when installing missing applications on an android device SM meraki

Hi all,

 

Same issue on my company...

 

Some days it looks to work some other no.

 

I have a case open for a month.

 

Hope they will fix soon.

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

I'm seeing this on my MDM test Org as well. 2 apps have been trying and failing to pull down for going on 2 weeks and the Play Store reports "Your administrator has not given you access to this item." Verified device is in-scope and app is approved in AFW. 

 

Since it's been a few months since this started for you all, anyone had luck getting it resolved? 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

hello 

this issue is a joke. 

I have the same issue with 4 customers since may and I can't have any information from meraki. 

I have opened many cas but the support don't know anything about this. 

 

I love meraki products but I have never been more upset about a technical issue. Very disappointed ...

 

any news for you guys ? 

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

Are there people from Meraki in this community ? I really need to have informations about this issue...

thanks 

Highlighted
Comes here often

Re: problems when installing missing applications on an android device SM meraki

We're operating on the free tier, but we have the same issue with certain devices and certain apps. In some cases the QR code did seem to make a difference versus using afw#meraki. In other cases it didn't matter how we setup the device, it would just refuse some apps and throw the same errors you guys are seeing in the Play store, etc.

Highlighted
Here to help

Re: problems when installing missing applications on an android device SM meraki

yes, 

we are still waiting for a fix from the support . 

we have tried many devices / many Android version, but still issues... 

 

really difficult to get any information from the support, not very serious. 

 

with iOS, meraki works well, with Android, it is a nightmare, ... really thinking of moving on another MDM...

Highlighted
New here

Re: problems when installing missing applications on an android device SM meraki

Hi,

 

Ran into the same issue setting up a demo for a client.

I solved this by synchronising the Android Enterprise Apps, then I could install it on the phones.

 

When I tried to aprove the apps when I installed them, I got a error saying that Aproval failed.

 

It seems that it's the Aproval for the app is missing.

You can see the last sync status under System Manager / Overview, and sync from here.

If you go under Systems Manager / Apps, and add the column "Android Enterprise Aproved" then you can see your aproval state. 

My Apps was not aproved, you can sync from the Overview or from the Apps page under accounts. After a sync, I could aprove the Apps, and they installed on the phones.

 

Hope this helps

Highlighted
Conversationalist

Re: problems when installing missing applications on an android device SM meraki

(Cross-copied from another similar thread)...

 

Ongoing case (04149194) on this Android app approval issue.

One factor that is certainly involved is a race condition between approval on Google Play Work website and approval in the SM Dashboard. It seems that unapproving on the Play Work web page then approving (only) on the SM Dashboard helps resolve the problem, at least in the short term.

I'll update this reply if I learn more - hope this helps someone.

New here

Re: problems when installing missing applications on an android device SM meraki

We have this issue too, Meraki support also useless for us.

 

I have found a workaround that is less disruptive than a factory reset:

 

o On the device go into the Meraki app

o Select Managed Apps from the menu
o Tap the install button next to the app name to access the play store

o In the Google Play store press the 3 lines icon/ menu button in the top left
o This should show a green bar with the android for work username in this format Android Enterprise User (xxxxx)
o In the Meraki Dashboard, change the device owner to the Android Enterprise user you noted down in the previous step
o Back on the device, go into the Meraki app, go to configuration, and click refresh. Ensure the last sync time shows this has synced
o Reboot the device (not sure if this step is needed?)
o Go back into the Meraki app
o You should now be able to install the app through managed apps as normal
o Once you have installed the apps you need to, go back into Meraki dashboard and change the owner back to the correct owner
o Go back into the Meraki app and refresh again. Make sure it has synced
o Reboot the device (not sure if this step is needed?)

 

Done!

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels