cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enable Cellular via API on MX68CW-WW

SOLVED
Here to help

Enable Cellular via API on MX68CW-WW

Has anyone an idea if it’s possible to enable the Cellular interface via API?

 

We got a big rollout with 2000+ branches to do and that’s the only point I wasn’t able to manage with my python script.

 

I didn’t find anything in the postman.

 

I hope I find a solution or a workaround the only solution is now to enable it manually.

 

Thanks for any help!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

@NolanHerring is right.  It just needs to connect once via the either wired WAN port to the Cloud, and then it is away after that.

 

11 REPLIES 11
Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

It's enable by default ... so nothing to do.

Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

Did they change that? Could of sworn you had to enable it first as it won't come online by itself, requiring the WAN1 to come online first.
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

The unit has to connect to the dashboard once to get an update.  So you can do this in staging.

 

Once that is done it is enabled.

Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

Ah ok that makes sense then.
Nolan Herring | nolanwifi.com
TwitterLinkedIn
Here to help

Re: Enable Cellular via API on MX68CW-WW

I will testit today the strange thing is before the unit is connectet for the first time to the dashboard on the dashboard the cellular interface is disabled..

 

Thanks for your help! 🙂

Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW


@Set753 wrote:

I will testit today the strange thing is before the unit is connectet for the first time to the dashboard on the dashboard the cellular interface is disabled..

 

Thanks for your help! 🙂


I think that is what @PhilipDAth and the documentation was saying.

 

You have to connect the MX67/68 first to the cloud via a normal uplink through WAN1/2 etc. Once that is done, and it can upgrade firmware and sync config etc., then the cell interface will kick into gear (in theory).

 

I think the last time I did an MX67C, I connected it to the cloud via WAN1, and I think I noticed that the cellular interface was neither enabled or disabled.  It was like neither option was chosen, but I was seeing some signal information, so it must have been 'on' in that sense.

 

I have more coming soon so I can test again

Nolan Herring | nolanwifi.com
TwitterLinkedIn
Highlighted
Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

@NolanHerring is right.  It just needs to connect once via the either wired WAN port to the Cloud, and then it is away after that.

 

Here to help

Re: Enable Cellular via API on MX68CW-WW

You are right.

 

After the device is connected for the fist time with the Cloud the cellular interface is activ and ready to use..

 

Thats good so i dont need to create some magic with my phyton script 😛

 

The big question is now why is the cellular modem disabled?

 

Thanks for your help guys!TEST.PNG

Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

>The big question is now why is the cellular modem disabled?

 

It needs a firmware update to work, which it gets the first time it connects.

Here to help

Re: Enable Cellular via API on MX68CW-WW

Yes i know but after the update the cellular modem is disbaled and its working fine you know what i mean? 🙂

Kind of a big deal

Re: Enable Cellular via API on MX68CW-WW

Just a follow up on this as I got two MX67C recently so I am testing this out.

 

First time powering this MX67C on

I already installed the AT&T NANO-SIM card

WAN 1 connection active

 

After a few minutes, it downloaded firmware and rebooted. The Cellular interface did not show anything until after the reboot. Then I saw it (live) populate information.

 

Screenshots below

 

Status only says 'READY'

 

When I click on the edit icon, it has 'disabled' already highlighted. Not sure if that means anything.

 

I manually selected Enabled and now the status shows 'READY, ENABLED'

 

So I'm pretty sure that we don't need to do anything (like clicking enabled). I'm going to test this on the second one and see if when I unplug WAN 1, the cellular kicks in automatically (without me doing anything GUI wise).

 

1111.jpg2222.jpg3333.jpg

Nolan Herring | nolanwifi.com
TwitterLinkedIn
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.