Create Organization API via Python Returns 403

Just browsing

Create Organization API via Python Returns 403

Hello all, 


I'm working on a Python script that it's current purpose is to create an organization. I'm working with the Meraki Python API library. that is recommended on the developer website. 


Whenever I run the function with my API key, I keep getting the 403 status - forbidden. I ran the same function with my co-worker's API key and it was able to successfully create a new organization. What settings do I need to change if any and where? We seem to have the same privileges across the board. 


Thanks in advance! 

Meraki Employee
Meraki Employee

Hi Jon,


This sounds like a permissions issue. You mentioned you have the same perms as your coworker but that seems unlikely if the same code worked differently for the two different keys.


If you have GUI access, compare the admin privileges in GUI:

Hi John, 


Thanks for the reply. I check again and I have full Organization admin access to each of the organizations I am in. Compared it once more to my co-worker's admin rights and they are the same. Or am I looking in the wrong spot? Any other suggestions?




Thank you!

Edited to remove text as reply posted as duplicate. Please refer to my other reply. 

Building a reputation

I have to agree with John here.


Think about it, if it works with his key and not with yours then its likely a perms issue. Did you recently change the perms? If so it can take a moment to update. Some times even Meraki can lag so try refreshing your perms as well.


Best of luck

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.