Certificate error when running api call from power automate

Fabio_Castaneda
New here

Certificate error when running api call from power automate

Hi, I am trying to build a flow in power automate to get some basic information from the Cisco Meraki cloud. I am able to run the  API call by using Postman, Python, PowerShell, however, whenever I try to run the same call from Power Automate desktop or cloud, I am getting the same error and It fails from the begininng. "

"Error de la solicitud HTTP con el código de estado \"TrustFailure\" y el mensaje de estado: \"The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.\"."
 
Details of the call:
 
Headers: 
{
  "Content-Type""application/json",
  "Accept""application/json",
  "X-Cisco-Meraki-API-Key""xxxxxxxxxxxxxxxxxxxxxx"
}
 
Of course it works from the Meraki site as well by providing the appropriate parameters.. 
 
I believe it is something related with the TLS certificate .... please I need your help...
 
Best Regards,
FAbio Castañeda 
1 REPLY 1
rbnielsen
Head in the Cloud

The megaproxy is being deprecated (if not already is..!), so try to avoid using that.

 

If you set the base url to api.meraki.com, what happens?

LinkedIn ::: http://rbnielsen.dk

Like what you see? - Give a Kudo ## Did it answer your question? - Mark it as a Solution 🙂
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.