WIndows 10 Machine Not Showing Up in Meraki Dashboard


WIndows 10 Machine Not Showing Up in Meraki Dashboard

I recently imaged a new Windows 10 machine and then installed the Meraki agent on it. After installing the Meraki agent, the machine doesn't show up in the Meraki Dashboard, and the agent log just has the following repeated over and over:


2018-11-15 12:40:42.101115 [01C566E0]: ConnState::sample_win_common(): NOT ASSOCIATED, not getting net states
2018-11-15 12:40:48.519628 [02627478]: TunClient::handle_request []: request


I've turned off the firewall to make sure that wasn't a blocker. I've confirmed I have Internet access. I've also pinged to ensure that was reachable. I've uninstalled and re-installed the agent twice. 


What does "not getting net states" mean? And what am I missing?

Kind of a big deal
Kind of a big deal



The agent you installed did you download a fresh copy or is it a nexsiting copy you had? Also it port 933 open on your firewall.


If you go to the  "Help > Firewall Info" menu on your dashboard it lists which ports need to be open to allow systems manager to work properly. 

Firewall is turned off. I downloaded a fresh copy.


I did forget that this machine was re-imaged and most likely was on Meraki before. The imaging process was a fresh install though. As a double-check, I uninstalled the agent, found the entry in the registry for the agent and deleted that entry, then re-installed the agent. That was about an hour ago, and it's still not showing up in Meraki.

@TheOtherTim I have seen in the past if a machine was registered in Meraki and then reimaged and renamed it appears back in Meraki with the old information i.e. its old hostname.


How are you searching for the device By name or serial number?

For what it's worth, I did at one point find the registry key for the Meraki agent, delete it, and re-install the agent.


Since then, I've given up on the first build and imaged a new machine that was never imaged before. And still have the same problem and same entries in the log. And firewall is turned off.


I've added to Device Manager the columns for LAN IP, Wifi Mac, and UUID and have tried searching by those.



Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.