Meraki Insight - Web App Health "No Data"

MerakiMed
Getting noticed

Meraki Insight - Web App Health "No Data"

I have VOIP Health checks working fine against our phone provider Ring Central. But then I added Skype, Ofice 365, One Drive and a few others to Web App Health and all of them read "Not Affected Networks and No Data". Is there something else I need to do for the MX to start running health checks against these services? 

 

Also - is the Office 365 check good for approximating the performance of Outlook for O365?

15 REPLIES 15
Roska
A model citizen

Re: Meraki Insight - Web App Health "No Data"

Takes some time to gather the data after you´ve configured the apps you want to track. This is the case here?

MerakiMed
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

I waited over night - but still every app shows nothing for any of those app performance metrics. I ran Outlook for Office 365 and Skype for business locally. It's unclear to me if the MX needs to see actual traffic in order to measure performance or it just creates simulated to traffic to develop its metrics. Could it be Office 365 measurement doesn't include Outlook for Office 365? Or perhaps Skype means consumer Skype and not Skype for Business. Kind of frustrating.

 

MerakiMed_0-1597156353138.png

 

Roska
A model citizen

Re: Meraki Insight - Web App Health "No Data"

OK, another question regarding your VPN setup on this MX, is it acting as hub/spoke in AutoVPN setup? I´m also thinking that you might need to setup a custom app approach if you have services hosted locally. Haven´t troubleshooted Insight on my MXs enough so I´m hoping for some of the experienced community members to share their views.

 

You might want to take a look at the Insight documentation page if you haven´t done it already.

 

https://documentation.meraki.com/

MerakiMed
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

I got it sorted out. It only appeared a laptop was running through the MX but it was actually routing over WiFi that did not run through the MX. That was due to earlier static configuration on the laptop for the Eth port. Once I got that sorted out monitoring started collected. It confirms that real traffic is required for MX to give feedback. And this also explains why VOIP monitoring was working as there is a working Ring Central phone directly attached to the MX.

Roska
A model citizen

Re: Meraki Insight - Web App Health "No Data"

Makes sense, glad its sorted.

chrishilton
Here to help

Re: Meraki Insight - Web App Health "No Data"

I have the same issue, but am not sure about the solution you have described.  Could you give more detail?

 

I have all traffic going through the MX.

MerakiMed
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

Hi Chris. In my case I presumed that Meraki was doing some kind of synthetic transaction in order to gain its statistics. That may be the case with VOIP where is asked for a destination server for Ring Central. But for most of the other checks it displayed no data until I had actual traffic flows. Once Skype started going through the MX for example, Skype and Outlook performance were displayed once I actually put a laptop downstream of the MX. At first I just had a Ring Central phone off the MX. The MX was part of my POC and I was verifying it would work before sending it out to branch offices. What application is not populating?

chrishilton
Here to help

Re: Meraki Insight - Web App Health "No Data"

None of the web app health metrics report any data.  Have tried Meraki support, and they came back with:

 

I spent some time on this case today and observed that your MX is currently in passthrough mode, which means the security appliance is acting as a Layer 2 bridge and does not route or translate client traffic

Only traffic that passes through an MX can be tracked by Meraki Insight. For example, if the MX is handling all routing for a location then both WAN bound and Inter-VLAN bound application traffic will be tracked. However, if Inter-VLAN routing is happening on a downstream device and only WAN bound traffic passes through the MX then only WAN bound application traffic will be tracked.

 

I'm a bit confused because all traffic goes through the MX and Meraki don't state in the documentation that Insight web app health does not work in passthrough mode.

chrishilton
Here to help

Re: Meraki Insight - Web App Health "No Data"

Answer: Open the relevant port outbound on the firewall

 

Source : LAN

Destination : 3.210.175.34/32, 13.52.29.190/32, 13.54.51.60/32, 35.161.241.24/32, 35.162.58.56/32, 35.162.65.76/32, 50.18.100.0/32, 52.33.92.73/32, 52.57.34.238/32, 52.59.68.120/32, 52.208.175.132/32, 198.27.154.12/32, 209.206.48.0/20

Ports : tcp/udp- 6514

richardbaux
New here

Re: Meraki Insight - Web App Health "No Data"

I don't think that's quite true. I have few MX in routing mode and they're perfectly sending data. 

 

I have just 1 that it's not and I have contacted support. Im currently waiting to hear from them.

thomasthomsen
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

Any news on this.

I have an MX that has been running for about a month with Insight but no data is present.

The MX is in "routed" mode, and has all the VLANs terminated on it.

I can see Office 365 and Skype data in the clients overview, but nothing shows up in Insights, even though selected Office 365, Azure, Skype and so on....

 

I just feel its strange.

 

Bruce
Kind of a big deal

Re: Meraki Insight - Web App Health "No Data"

@thomasthomsen what MX code are you running? It was broken in MX15 at one stage, and then fixed in the last six months or so, but I believe it’s broken again in the MX16 train - hopefully Meraki can fix it again in the next MX16 firmware update.

thomasthomsen
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

Ahh running 16.x here (because of Anyconnect). That might be it.

chrishilton
Here to help

Re: Meraki Insight - Web App Health "No Data"

I solved this by allowing the relevant port on an upstream firewall at our ISP.  Don't remember the exact port, but you can find the details of the ports that need to be allowed in Firewall Info on the dashboard.

 

chrishilton_0-1622889939431.png

 

thomasthomsen
Getting noticed

Re: Meraki Insight - Web App Health "No Data"

Well there is no upstream firewall.

And if there was, should the Meraki dashboard then not tell me that there is something missing.

Its just strange.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.