Android enrolling communication error / register_android

New here

Android enrolling communication error / register_android

I am trying to enroll a new android device to cisco meraki with Meraki SM app, but when I start the enroll procedure


I get the error "Could not communicate to server". Debugging the connections with ADB tool I see it's trying to reach out for with communication error


If I place the link in a browser I reach a Page not found error.


Is this known issue? Any possibility to continue enrolling my android devices?


5 Replies 5
Kind of a big deal
Kind of a big deal

Is the version of Android on the device up to date? Does it have any outstanding manufacturer updates that can be applied?


Another issue is that sometimes you need a new version of Google Play on the device if it is using an older Android flavour.

An old message, but I am having the exact same problem.

I have completed all updates and play store updates, but get the error message.

I did have a work round where a QR code would work, but now it is unable to connect to server regardless.


Samsung Galaxy A10 

I am also getting this same error "Cannot communicate with Server" upon enrollment of Android devices. Worked with a Meraki tech and he said "it should be working" 



I worked out a fix that seems ridiculous, but actually works.

In Meraki go to Systems Manager -- Add devices -- Android - device owner mode - this will then give you two qr codes.

When you open System manager instead of typing in the code scan the QR code and it will register!!!



We found the QR code works too. But the bigger question is why isnt the Enrollment Code working all of a sudden. Come on Meraki. 

Get notified when there are additional replies to this discussion.