Can Client VPN on a MX68 work through an MG41?

VascoFCosta
Getting noticed

Can Client VPN on a MX68 work through an MG41?

Hi,

I've configured Client VPN in a MX68 that is connected to the Internet through a MG41.

Whenever I try to connect remotely to the Client VPN (tried with a windows laptop, macbook and ipad), I get the message "L2TP failed to answer" and I start the packet capture, there's nothing on the MX68.

Is the MG41 the issue?
Is there a config step missing in the config guide?

Thanks,
Vasco


Cheers,
Vasco
____________
@VascoFCosta
Found this helpful? Please give me some Kudos!
2 Replies 2
alemabrahao
Kind of a big deal
Kind of a big deal

Have you configured a public IP or private IP on MX Wan interface?

 

If it was configured with private IP you need to create a NAT policy,  if was configured with a public IP I suggest you to review the L2TP configuration.

 

Or Maybe you should have to open a support case.

I am not a Cisco Meraki employee. My suggestions are based on documentation of Meraki best practices and day-to-day experience.

Please, if this post was useful, leave your kudos and mark it as solved.
PhilipDAth
Kind of a big deal
Kind of a big deal

This one was trouble al over it.

 

As @alemabrahao mentions, it will only work if you can get a public IP directly on the MG41.  If you are using the Microsoft client VPN, then you need to add extra registry keys to allow it to work through NAT.  My client VPN wizard creates a powershell script to configure the VPN on Windows and it also adds the registry key entries.

https://www.ifm.net.nz/cookbooks/meraki-client-vpn.html 

 

If you have a public IP on your MG41, you could also consider buying Cisco ANyConnect licences and using that instead.

https://documentation.meraki.com/MX/Client_VPN/AnyConnect_on_the_MX_Appliance 

Get notified when there are additional replies to this discussion.