softphone Voip on mr33

SOLVED
celma972
Comes here often

softphone Voip on mr33

Dear all,

 

We have 33 x Meraki MR33 placed at 15 meter height from the ground in a warehouse. We are using the 2.4Ghz band with one SSID for the RF devices (Android guns and forklift terminals).

 

We create a new SSID with the following settings for Android smartphone son which we are using a Voip softphone

Capture d’écran 2021-04-19 à 23.29.20.png

The issue we are experiencing is we have choppy calls and poor quality voice.

Could you give some clues how to optimize the calls?

 

Thks

1 ACCEPTED SOLUTION

Accepted Solutions
Bruce
Kind of a big deal

Re: softphone Voip on mr33

If people are walking around the facility while making VoIP calls then you will should always have roaming. As they move further from the original access point they will eventually switch to a new access point - this is perfectly normal and is how wireless should work.

 

As @cmr states, in NAT mode with Meraki DHCP as you currently have, the access point is changing the source IP address of the wireless device from whatever it is on the wireless network to the IP address of the access point. In this mode when you roam this NAT changes since you're using a different access point with a different IP address. This will potentially cause a gap in the audio.

 

Using bridge mode the client keeps its IP address (which is issued by a DHCP server somewhere else on your network) and uses well known protocols to transition from one access point to the other, ensuring this is a fast transition and that you don't get any packet loss - so maintaining the packet flow and giving a much better experience to the user.

 

Like @RupertDot11 states, I'd also be concerned about the height of the access points. At 15m you'd really want to make sure that your wireless site survey was done to take this into account. At 15m, you're losing around 60dB on your signal between the AP and the floor, and if your APs are set for Auto Power management then they may be 'seeing' each other better than the clients and so winding their power back (do you know the maximum power of the radios in the client devices?). This doesn't mean it can't work, you just need to make sure that the RF side has been engineered correctly.

 

I see you're also using the 2.4GHz spectrum too. This is often a noisy and over utilized spectrum, but I recognize this may be a limitation of the clients - the 5GHz may be better. You may find there is significant background noise that it causing problems. Again this is a RF engineering issue and you may need to get someone out on site to measure this with the correct tools.

View solution in original post

6 REPLIES 6
RupertDot11
Meraki Employee

Re: softphone Voip on mr33

15 meters is pretty close to the edge of a typical cell edge in an office environment where MR33 would propagate it signal in a donut shape.  That may be your issue, particularly for VoIP.  One possible issues you can address:

 

- APs at the ceiling level can see each other pretty hot and reduce TX power to adjust what it thinks is high-density deployment;  however, client devices at the floor levels are too far to use lower TX power levels;  try adjusting the minimum TX power in the Radio profiles to be no less than 14dBm (the typical max supported by smartphones)

 

If it doesn't resolve or improve your issue, I'd revisit proper coverage via an RF validation

cmr
Kind of a big deal
Kind of a big deal

Re: softphone Voip on mr33

@celma972 I see you have selected Meraki DHCP, this means that the AP is performing NAT and effectively each AP has a separate network.  If a client device tries to roam from one AP to another you will get packet loss and a gap in the call.

 

You want bridge mode and a VLAN at the backend just for voice.  That should help you a lot.

celma972
Comes here often

Re: softphone Voip on mr33

Hi cmr,

 

I will have the same issue if I am on bridge mode, because the voice devices will roam as well, correct?

 

 

Bruce
Kind of a big deal

Re: softphone Voip on mr33

If people are walking around the facility while making VoIP calls then you will should always have roaming. As they move further from the original access point they will eventually switch to a new access point - this is perfectly normal and is how wireless should work.

 

As @cmr states, in NAT mode with Meraki DHCP as you currently have, the access point is changing the source IP address of the wireless device from whatever it is on the wireless network to the IP address of the access point. In this mode when you roam this NAT changes since you're using a different access point with a different IP address. This will potentially cause a gap in the audio.

 

Using bridge mode the client keeps its IP address (which is issued by a DHCP server somewhere else on your network) and uses well known protocols to transition from one access point to the other, ensuring this is a fast transition and that you don't get any packet loss - so maintaining the packet flow and giving a much better experience to the user.

 

Like @RupertDot11 states, I'd also be concerned about the height of the access points. At 15m you'd really want to make sure that your wireless site survey was done to take this into account. At 15m, you're losing around 60dB on your signal between the AP and the floor, and if your APs are set for Auto Power management then they may be 'seeing' each other better than the clients and so winding their power back (do you know the maximum power of the radios in the client devices?). This doesn't mean it can't work, you just need to make sure that the RF side has been engineered correctly.

 

I see you're also using the 2.4GHz spectrum too. This is often a noisy and over utilized spectrum, but I recognize this may be a limitation of the clients - the 5GHz may be better. You may find there is significant background noise that it causing problems. Again this is a RF engineering issue and you may need to get someone out on site to measure this with the correct tools.

View solution in original post

celma972
Comes here often

Re: softphone Voip on mr33

Hi Bruce,

The AP are used for Androids Gun, Forklift terminals and VoCollect talkman terminals in the warehouse. We are using the 2.4Ghz band for them. This is the configuration

celma972_0-1619430504656.png

According to the elements I have given, can you help me to establish an action plan to use the existing APs with Android mobile phones without a SIM card (I would only like to use WIFI). Knowing that the APs are Meraki MR33s located at about 15m height from the ground. We had already carried out a site survey for the installation of guns, forklift and Voicecollect terminak three years ago.

 

Thks for your help

 

Bruce
Kind of a big deal

Re: softphone Voip on mr33

It's a bit hard to assist remotely, but I can make some suggestions.

Was the site survey done as a 'predictive' survey, or did you have one done after all the access points were installed and configured. If you haven't had an active site survey done since the installation you should really do that to understand what the RF looks like. You should also do a new site survey if there have been any changes in neighboring buildings or their occupancy (new tenants can mean they're generating new interference).

You also need to look at the capability of the devices you're using. If they can all make use of 802.11a/g/n (i.e. no 802.11b) then you should be setting a minimum bitrate of 12Mbps - this disables 802.11b which will improve overall performance of the network, which you need for VoIP (802.11b is unsuitable for wireless VoIP).

What's the approximate distance between access points? Are they mounted on steel beams or similar?

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.